aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-07-22 08:11:36 +0800
committerbeech <beech@FreeBSD.org>2008-07-22 08:11:36 +0800
commitfd5db08a2e36d69a10dfaf57c3712f2b0cb5e3f5 (patch)
treefde24111dcdc279fbed8301a085deb21cddaba3e /science
parentc8747c710a244c55fec9a08671c1bd41dc82ed5c (diff)
downloadfreebsd-ports-gnome-fd5db08a2e36d69a10dfaf57c3712f2b0cb5e3f5.tar.gz
freebsd-ports-gnome-fd5db08a2e36d69a10dfaf57c3712f2b0cb5e3f5.tar.zst
freebsd-ports-gnome-fd5db08a2e36d69a10dfaf57c3712f2b0cb5e3f5.zip
- Turn off the python module as it causes breakage in the build cluster.
- While here, rename the BROWSER option to SILEXB to avoid confusion. - No version bump since no package has been built. PR: ports/125846 Submitted by: Pedro F. Giffuni <giffunip@tutopia.com> (maintainer) Reported by: pointyhat via erwin
Diffstat (limited to 'science')
-rw-r--r--science/silo/Makefile13
-rw-r--r--science/silo/pkg-plist2
2 files changed, 8 insertions, 7 deletions
diff --git a/science/silo/Makefile b/science/silo/Makefile
index 4e92518570d8..dd28a56ca1dc 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -28,16 +28,17 @@ USE_XLIB= yes
USE_QT_VER= 3
QT_COMPONENTS= moc uic
-OPTIONS= PYTHON "Enable Python Module" On \
+OPTIONS= PYTHON "Enable Python Module" Off \
HDF5 "Enable HDF5 Driver" Off \
- BROWSER "Enable Silex Browser" Off \
+ SILEXB "Enable Silex Browser" Off \
FORTRAN "Compile Fortran interface" Off \
OPTIMIZATION "Enable extra optimizations" On
+USE_PYTHON= yes
+
.include <bsd.port.pre.mk>
.ifdef WITH_PYTHON
-USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-pythonmodule
PLIST_SUB+= WITH_PYTHON=""
.else
@@ -54,11 +55,11 @@ PLIST_SUB+= WITH_HDF5="@comment "
PLIST_SUB+= WITH_NCDF=""
.endif
-.ifdef WITH_BROWSER
+.ifdef WITH_SILEXB
CONFIGURE_ARGS+= --enable-silex
-PLIST_SUB+= WITH_BROWSER=""
+PLIST_SUB+= WITH_SILEXB=""
.else
-PLIST_SUB+= WITH_BROWSER="@comment "
+PLIST_SUB+= WITH_SILEXB="@comment "
.endif
.ifdef WITH_FORTRAN
diff --git a/science/silo/pkg-plist b/science/silo/pkg-plist
index 48a489b9e50f..c3ecbd8846ae 100644
--- a/science/silo/pkg-plist
+++ b/science/silo/pkg-plist
@@ -1,4 +1,4 @@
-%%WITH_BROWSER%%bin/browser
+%%WITH_SILEXB%%bin/browser
bin/silodiff
bin/silex
bin/silock