aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-04-18 04:31:45 +0800
committerthierry <thierry@FreeBSD.org>2014-04-18 04:31:45 +0800
commit70125968961e52269ac318b0e1774c8b18e5b23e (patch)
treebd5e0e1cccf75353ee29e011d90071f115f69e71 /science
parentca4740c90eae1b4a1b6edc5d26376f68c9d4304f (diff)
downloadfreebsd-ports-gnome-70125968961e52269ac318b0e1774c8b18e5b23e.tar.gz
freebsd-ports-gnome-70125968961e52269ac318b0e1774c8b18e5b23e.tar.zst
freebsd-ports-gnome-70125968961e52269ac318b0e1774c8b18e5b23e.zip
- Upgrade cgnslib to 3.2.1
Changelog at <https://sourceforge.net/projects/cgns/files/cgnslib_3.2/> - Bump PORTREVISION of consumers ports.
Diffstat (limited to 'science')
-rw-r--r--science/cgnslib/Makefile14
-rw-r--r--science/cgnslib/distinfo4
-rw-r--r--science/cgnslib/pkg-plist149
-rw-r--r--science/ecs/Makefile2
-rw-r--r--science/fvm/Makefile2
5 files changed, 22 insertions, 149 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index 55ccd98e5843..ceeea807d19b 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cgnslib
-DISTVERSION= 3.1.4
-PORTREVISION= 2
+DISTVERSION= 3.2.1
PORTEPOCH= 1
CATEGORIES= science
MASTER_SITES= SF/cgns/${PORTNAME}_${PORTVERSION:R}/
@@ -29,25 +28,24 @@ SZIP_DESC= SZIP support in HDF5
OPTIONS_DEFAULT=HDF5 TESTS TOOLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHDF5}
LIB_DEPENDS+= libhdf5.so.7:${PORTSDIR}/science/hdf5-18
-CMAKE_ARGS+= -DENABLE_HDF5:BOOL=TRUE -DHDF5_NEED_ZLIB:BOOL=TRUE \
+CMAKE_ARGS+= -DCGNS_ENABLE_HDF5:BOOL=TRUE -DHDF5_NEED_ZLIB:BOOL=TRUE \
-DHDF5_INCLUDE_PATH:PATH="${LOCALBASE}/include"
PLIST_SUB= HDF5=""
. if ${PORT_OPTIONS:MSZIP}
CMAKE_ARGS+= -DHDF5_NEED_SZIP:BOOL=OFF
. endif
.else
-CMAKE_ARGS+= -DENABLE_HDF5:BOOL=OFF
+CMAKE_ARGS+= -DCGNS_ENABLE_HDF5:BOOL=OFF
PLIST_SUB= HDF5="@comment "
.endif
.if ${PORT_OPTIONS:MTESTS}
USES+= fortran
-CMAKE_ARGS+= -DENABLE_TESTS:BOOL=TRUE -DENABLE_FORTRAN:BOOL=TRUE
+CMAKE_ARGS+= -DCGNS_ENABLE_TESTS:BOOL=TRUE -DCGNS_ENABLE_FORTRAN:BOOL=TRUE
TESTSBIN= cgwrite cgread test_partial
.endif
@@ -55,7 +53,7 @@ TESTSBIN= cgwrite cgread test_partial
USES+= tk
USE_GL= gl glu
USE_XORG= xmu
-CMAKE_ARGS+= -DBUILD_CGNSTOOLS:BOOL=TRUE \
+CMAKE_ARGS+= -DCGNS_BUILD_CGNSTOOLS:BOOL=TRUE \
-DTCL_INCLUDE_PATH:STRING="${TCL_INCLUDEDIR}" \
-DTK_INCLUDE_PATH:STRING="${TK_INCLUDEDIR}"
PLIST_SUB= TOOLS=""
@@ -73,6 +71,6 @@ regression-test:
.endif
post-install:
- ${LN} -sf ${PREFIX}/lib/libcgns.so.${LIBVER} ${PREFIX}/lib/libcgns.so.${LIBVER:R}
+ ${LN} -sf libcgns.so.${LIBVER} ${STAGEDIR}${PREFIX}/lib/libcgns.so.${LIBVER:R}
.include <bsd.port.mk>
diff --git a/science/cgnslib/distinfo b/science/cgnslib/distinfo
index 078831d2144b..2cb7886fd7fe 100644
--- a/science/cgnslib/distinfo
+++ b/science/cgnslib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cgnslib_3.1.4.tar.gz) = c07a84bc780da0ea28446ad25e8af6e6b7999fd9cb053ec2de24678001b8b932
-SIZE (cgnslib_3.1.4.tar.gz) = 1589501
+SHA256 (cgnslib_3.2.1.tar.gz) = 34306316f04dbf6484343a4bc611b3bf912ac7dbc3c13b581defdaebbf6c1fc3
+SIZE (cgnslib_3.2.1.tar.gz) = 865223
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
index 940b0b40283a..906ea1201eb5 100644
--- a/science/cgnslib/pkg-plist
+++ b/science/cgnslib/pkg-plist
@@ -9,8 +9,11 @@ bin/cgnslist
bin/cgnsnames
bin/cgnsnodes
bin/cgnsplot
+%%TOOLS%%bin/cgnstools/aflr3_to_cgns
%%TOOLS%%bin/cgnstools/calcwish
%%TOOLS%%bin/cgnstools/cgiowish
+%%TOOLS%%bin/cgnstools/cgns_to_aflr3
+%%TOOLS%%bin/cgnstools/cgns_to_fast
%%TOOLS%%bin/cgnstools/cgns_to_plot3d
%%TOOLS%%bin/cgnstools/cgns_to_tecplot
%%TOOLS%%bin/cgnstools/cgns_to_vtk
@@ -18,18 +21,21 @@ bin/cgnsplot
%%TOOLS%%bin/cgnstools/convert_location
%%TOOLS%%bin/cgnstools/convert_variables
%%TOOLS%%bin/cgnstools/extract_subset
+%%TOOLS%%bin/cgnstools/fast_to_cgns
%%TOOLS%%bin/cgnstools/interpolate_cgns
%%TOOLS%%bin/cgnstools/patran_to_cgns
%%TOOLS%%bin/cgnstools/plot3d_to_cgns
%%TOOLS%%bin/cgnstools/plotwish
%%TOOLS%%bin/cgnstools/tecplot_to_cgns
+%%TOOLS%%bin/cgnstools/tetgen_to_cgns
+%%TOOLS%%bin/cgnstools/vgrid_to_cgns
bin/cgnsupdate
-bin/cgnsversion
bin/cgnsview
bin/hdf2adf
bin/unitconv
include/cgnsBuild.defs
include/cgns_io.h
+include/cgnsconfig.h
include/cgnslib.h
include/cgnslib_f.h
include/cgnstypes.h
@@ -38,7 +44,8 @@ include/cgnswin_f.h
lib/libcgns.a
lib/libcgns.so
lib/libcgns.so.3
-lib/libcgns.so.3.1
+lib/libcgns.so.3.2
+%%TOOLS%%share/cgnstools/aflr3.tcl
%%TOOLS%%share/cgnstools/balloon.tcl
%%TOOLS%%share/cgnstools/cgns-icon.xbm
%%TOOLS%%share/cgnstools/cgns-mask.xbm
@@ -66,138 +73,11 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/dimensional.cnv
%%TOOLS%%share/cgnstools/editfile.tcl
%%TOOLS%%share/cgnstools/export.tcl
+%%TOOLS%%share/cgnstools/fast.tcl
%%TOOLS%%share/cgnstools/filesel.tcl
%%TOOLS%%share/cgnstools/findfile.tcl
%%TOOLS%%share/cgnstools/frame.tcl
%%TOOLS%%share/cgnstools/help.tcl
-%%TOOLS%%share/cgnstools/help/cgnsplot/base.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/cgnsplot.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/cutting.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/defaults.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/display.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/graphics.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/help.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/axes_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/backface_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/base_sel.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/center_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cgnsplot.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutplane.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutting_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutview.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/display_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/error.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/file_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/graphics.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/lighting_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/open_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/options_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/perspective.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/perspective_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/popup.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/region_info.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/reset_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/separator.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/setup.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/setup_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/status.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/tree.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/menu.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/perspective.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/separator.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/status.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/toolbar.html
-%%TOOLS%%share/cgnstools/help/cgnsview/buttons.html
-%%TOOLS%%share/cgnstools/help/cgnsview/cgnsnodes.html
-%%TOOLS%%share/cgnstools/help/cgnsview/cgnsview.html
-%%TOOLS%%share/cgnstools/help/cgnsview/customize.html
-%%TOOLS%%share/cgnstools/help/cgnsview/datadesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/dialogs.html
-%%TOOLS%%share/cgnstools/help/cgnsview/images/autosize_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/calc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/cgnsview.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/check.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/check_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/clear_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/collapse.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/command.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/config_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/convert.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/create_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/custom_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/datadesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/datasize.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/delete_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/expand.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/export.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/fileinfo_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/find.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/find_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/findagain.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/folder-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/folder.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/follow.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/help.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/help_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/helpsetup_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/import.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/invalid.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/linkdesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/linknode_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/modify_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/new.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodedata.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodedesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodeinfo.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/noderef.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodetree.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/open.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/plot.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/popup.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/properties.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/question-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/question.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/read_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/refresh.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/save.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/separator.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/tools_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/tree_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/unitconv.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/units.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/update.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/utility.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/version_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/linkdesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/menu.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodedata.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodedesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodetree.html
-%%TOOLS%%share/cgnstools/help/cgnsview/separator.html
-%%TOOLS%%share/cgnstools/help/cgnsview/toolbar.html
-%%TOOLS%%share/cgnstools/help/cgnsview/unitconv.html
-%%TOOLS%%share/cgnstools/help/utilities/convert.html
-%%TOOLS%%share/cgnstools/help/utilities/export.html
-%%TOOLS%%share/cgnstools/help/utilities/images/dimensionalization.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/export_plot3d.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/export_tecplot.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/extract_subset.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_patran.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_plot3d.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_tecplot.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_user.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/interpolate_solution.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/solution_location.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/solution_variables.gif
-%%TOOLS%%share/cgnstools/help/utilities/import.html
-%%TOOLS%%share/cgnstools/help/utilities/subset.html
-%%TOOLS%%share/cgnstools/help/utilities/utilities.html
%%TOOLS%%share/cgnstools/import.tcl
%%TOOLS%%share/cgnstools/menubar.tcl
%%TOOLS%%share/cgnstools/patran.tcl
@@ -206,6 +86,7 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/tclIndex
%%TOOLS%%share/cgnstools/tclreg.tcl
%%TOOLS%%share/cgnstools/tecplot.tcl
+%%TOOLS%%share/cgnstools/tetgen.tcl
%%TOOLS%%share/cgnstools/tkdir.tcl
%%TOOLS%%share/cgnstools/tools.tcl
%%TOOLS%%share/cgnstools/tree.tcl
@@ -216,13 +97,7 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/units.tcl
%%TOOLS%%share/cgnstools/util.tcl
%%TOOLS%%share/cgnstools/utilities.mnu
+%%TOOLS%%share/cgnstools/vgrid.tcl
%%TOOLS%%share/cgnstools/vtk.tcl
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsview/images
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsview
-%%TOOLS%%@dirrm share/cgnstools/help/utilities/images
-%%TOOLS%%@dirrm share/cgnstools/help/utilities
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsplot/images
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsplot
-%%TOOLS%%@dirrm share/cgnstools/help
%%TOOLS%%@dirrm share/cgnstools
%%TOOLS%%@dirrm bin/cgnstools
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index cb6dd92335e7..cdc0defe1f62 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ecs
PORTVERSION= 2.0.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index ae9ff12745a1..66907d0227c8 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvm
PORTVERSION= 0.15.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science parallel
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}