aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-06-19 02:09:16 +0800
committerdbn <dbn@FreeBSD.org>2017-06-19 02:09:16 +0800
commit0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8 (patch)
tree237480885bd130394dbcbc56f765540bba4416e2 /science
parent11eeef0a6a4a782ac0360e0d09460c3186dc0fde (diff)
downloadfreebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.tar.gz
freebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.tar.zst
freebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.zip
qa: add check for NO_ARCH
If NO_ARCH is set then check that no FreeBSD elf(5) files are in $STAGEDIR. If an elf(5) file is bundles as part of the package, but is not meant to be run directly (i.e. the elf(5) file is a payload, and not compiled) then those files can be added to NO_ARCH_IGNORE to avoid the check from failing, Changes to ports: - Ports that have NO_ARCH set, but actually compile files have had NO_ARCH removed. - Ports that have elf(5) payloads have had those files added to NO_ARCH_IGNORE. - R-cran ports that do not set USES=cran:compiles have NO_ARCH set, PR: 218976 Reviewed by: antoine, mat Approved by: portmgr
Diffstat (limited to 'science')
-rw-r--r--science/R-cran-AMORE/Makefile4
-rw-r--r--science/R-cran-DCluster/Makefile3
-rw-r--r--science/R-cran-bayesm/Makefile3
-rw-r--r--science/R-cran-cmprsk/Makefile3
-rw-r--r--science/R-cran-eco/Makefile4
-rw-r--r--science/R-cran-etm/Makefile3
6 files changed, 12 insertions, 8 deletions
diff --git a/science/R-cran-AMORE/Makefile b/science/R-cran-AMORE/Makefile
index f188dfae9447..f26189bf3a7a 100644
--- a/science/R-cran-AMORE/Makefile
+++ b/science/R-cran-AMORE/Makefile
@@ -3,7 +3,7 @@
PORTNAME= AMORE
PORTVERSION= 0.2.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
DISTNAME= ${PORTNAME}_${PORTVERSION:C/\./-/g:C/-/./1}
@@ -13,6 +13,6 @@ COMMENT= MORE flexible neural network package
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/science/R-cran-DCluster/Makefile b/science/R-cran-DCluster/Makefile
index 1c72d7700061..beb50e609d86 100644
--- a/science/R-cran-DCluster/Makefile
+++ b/science/R-cran-DCluster/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= DCluster
+PORTREVISION= 1
DISTVERSION= 0.2-7
CATEGORIES= science
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -14,6 +15,6 @@ LICENSE_COMB= dual
RUN_DEPENDS= R-cran-spdep>0:math/R-cran-spdep
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/science/R-cran-bayesm/Makefile b/science/R-cran-bayesm/Makefile
index fd504b5aeff2..6400e7a2ab5e 100644
--- a/science/R-cran-bayesm/Makefile
+++ b/science/R-cran-bayesm/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= bayesm
+PORTREVISION= 1
DISTVERSION= 3.0-2
CATEGORIES= science
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -14,6 +15,6 @@ LICENSE_COMB= dual
RUN_DEPENDS= R-cran-RcppArmadillo>=0:math/R-cran-RcppArmadillo
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/science/R-cran-cmprsk/Makefile b/science/R-cran-cmprsk/Makefile
index 904e8dfd3c51..75fee70af9c8 100644
--- a/science/R-cran-cmprsk/Makefile
+++ b/science/R-cran-cmprsk/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= cmprsk
+PORTREVISION= 1
DISTVERSION= 2.2-7
CATEGORIES= science
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -12,6 +13,6 @@ COMMENT= Subdistribution Analysis of Competing Risks
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/science/R-cran-eco/Makefile b/science/R-cran-eco/Makefile
index c13b3f6c1eda..f49d51050587 100644
--- a/science/R-cran-eco/Makefile
+++ b/science/R-cran-eco/Makefile
@@ -3,13 +3,13 @@
PORTNAME= eco
PORTVERSION= 3.1.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
DISTNAME= ${PORTNAME}_${PORTVERSION:C/\./-/g:C/-/./1}
MAINTAINER= wen@FreeBSD.org
COMMENT= R Package for Ecological Inference in 2x2 Tables
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/science/R-cran-etm/Makefile b/science/R-cran-etm/Makefile
index a3fb154a0fe7..8586dcc7a5be 100644
--- a/science/R-cran-etm/Makefile
+++ b/science/R-cran-etm/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= etm
+PORTREVISION= 1
DISTVERSION= 0.6-2
CATEGORIES= science
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -12,6 +13,6 @@ COMMENT= Empirical Transition Matrix
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>