aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
commit612bc3c9c8698b6a8cdbb965267678a0ac829218 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /science
parent83574ff9450fce1ff644a38992000262dfd6586b (diff)
downloadfreebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.gz
freebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.zst
freebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.zip
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Diffstat (limited to 'science')
-rw-r--r--science/qtresistors/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/science/qtresistors/Makefile b/science/qtresistors/Makefile
index bfd20933862c..1345559735d1 100644
--- a/science/qtresistors/Makefile
+++ b/science/qtresistors/Makefile
@@ -11,17 +11,14 @@ DISTNAME= 118297-qtResistors-201001102229
MAINTAINER= vg@FreeBSD.org
COMMENT= Calculate resistance of resistor by the colors on the resistor
-USE_QT4= gui qmake_build uic_build moc_build
+USES= qmake
+USE_QT4= gui uic_build moc_build
WRKSRC= ${WRKDIR}/qtResistors
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS}
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/qtResistors ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qtResistors ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>