aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-04-02 23:27:22 +0800
committermiwi <miwi@FreeBSD.org>2010-04-02 23:27:22 +0800
commit6c421159640713682689df409863576efa491038 (patch)
tree11ac9a834656ae69b16ab5dddf0e5a84b598a381 /science
parente13ef43e406ec59b8bd03d39e560cd72a6a730ad (diff)
downloadfreebsd-ports-gnome-6c421159640713682689df409863576efa491038.tar.gz
freebsd-ports-gnome-6c421159640713682689df409863576efa491038.tar.zst
freebsd-ports-gnome-6c421159640713682689df409863576efa491038.zip
Perl module which provides some basic methods for representing a ring.
WWW: http://search.cpan.org/dist/Chemistry-Ring/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Chemistry-Ring/Makefile27
-rw-r--r--science/p5-Chemistry-Ring/distinfo3
-rw-r--r--science/p5-Chemistry-Ring/pkg-descr3
-rw-r--r--science/p5-Chemistry-Ring/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 1babf5a94abe..18b0abd7e590 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -110,6 +110,7 @@
SUBDIR += p5-Chemistry-MacroMol
SUBDIR += p5-Chemistry-Mol
SUBDIR += p5-Chemistry-Pattern
+ SUBDIR += p5-Chemistry-Ring
SUBDIR += p5-Geo-ReadGRIB
SUBDIR += p5-Geo-WebService-Elevation-USGS
SUBDIR += paje
diff --git a/science/p5-Chemistry-Ring/Makefile b/science/p5-Chemistry-Ring/Makefile
new file mode 100644
index 000000000000..81907ec51828
--- /dev/null
+++ b/science/p5-Chemistry-Ring/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Chemistry-Ring
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Ring
+PORTVERSION= 0.20
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Represent a ring as a substructure of a molecule
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+
+MAN3= Chemistry::Ring.3 Chemistry::Ring::Find.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Ring/distinfo b/science/p5-Chemistry-Ring/distinfo
new file mode 100644
index 000000000000..b8d1923e542d
--- /dev/null
+++ b/science/p5-Chemistry-Ring/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Ring-0.20.tar.gz) = b3c94e5ee85e959737aaadb85c3b8497
+SHA256 (Chemistry-Ring-0.20.tar.gz) = 996d3b306763bc61e4ee4da6d6bb760a92a2a4dcd54a485bce59d31472d29b24
+SIZE (Chemistry-Ring-0.20.tar.gz) = 9274
diff --git a/science/p5-Chemistry-Ring/pkg-descr b/science/p5-Chemistry-Ring/pkg-descr
new file mode 100644
index 000000000000..00c2eec12763
--- /dev/null
+++ b/science/p5-Chemistry-Ring/pkg-descr
@@ -0,0 +1,3 @@
+Perl module which provides some basic methods for representing a ring.
+
+WWW: http://search.cpan.org/dist/Chemistry-Ring/
diff --git a/science/p5-Chemistry-Ring/pkg-plist b/science/p5-Chemistry-Ring/pkg-plist
new file mode 100644
index 000000000000..cf0cae7f3ad5
--- /dev/null
+++ b/science/p5-Chemistry-Ring/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/mach/auto/Chemistry/Ring/.packlist
+%%SITE_PERL%%/Chemistry/Ring/Find.pm
+%%SITE_PERL%%/Chemistry/Ring.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Ring
+@dirrmtry %%SITE_PERL%%/Chemistry/Ring