aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-14 09:14:56 +0800
committermaho <maho@FreeBSD.org>2007-07-14 09:14:56 +0800
commit89df5b245e1c190cfeade377b7516df3f0f6de61 (patch)
tree846f318bbaeea035da2c989a2fb8ee73f6024ce0 /science
parent607290f885686286d5c43db90f18f3231187d075 (diff)
downloadfreebsd-ports-gnome-89df5b245e1c190cfeade377b7516df3f0f6de61.tar.gz
freebsd-ports-gnome-89df5b245e1c190cfeade377b7516df3f0f6de61.tar.zst
freebsd-ports-gnome-89df5b245e1c190cfeade377b7516df3f0f6de61.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'science')
-rw-r--r--science/2dhf/Makefile7
-rw-r--r--science/at/Makefile5
2 files changed, 3 insertions, 9 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
index c27291c09de1..a10a64d9f4a6 100644
--- a/science/2dhf/Makefile
+++ b/science/2dhf/Makefile
@@ -18,7 +18,7 @@ COMMENT= A Numerical Hartree-Fock Program for Diatomic Molecules
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.if defined(WITH_INTEL)
-BUILD_DEPENDS+= ${LOCALBASE}/intel_fc_80/bin/ifort:${PORTSDIR}/lang/ifc
+USE_FORTRAN= ifort
BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
@@ -34,10 +34,7 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
diff --git a/science/at/Makefile b/science/at/Makefile
index dab29bdc4d9d..af4a0c84795e 100644
--- a/science/at/Makefile
+++ b/science/at/Makefile
@@ -16,10 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Acoustic ToolBox includes four acoustic models
WRKSRC= ${WRKDIR}/at
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
post-patch:
@${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/Bellhop/Makefile