aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-02-19 15:30:58 +0800
committermaho <maho@FreeBSD.org>2007-02-19 15:30:58 +0800
commitc6bd4e745011d44cffbf186d5942d79d60e3f80e (patch)
tree564571e920d66552eb637f86032646dd34e7d933 /science
parent1cb1ad8745c9ab96b09a7732c28e1c5ad72f6edd (diff)
downloadfreebsd-ports-gnome-c6bd4e745011d44cffbf186d5942d79d60e3f80e.tar.gz
freebsd-ports-gnome-c6bd4e745011d44cffbf186d5942d79d60e3f80e.tar.zst
freebsd-ports-gnome-c6bd4e745011d44cffbf186d5942d79d60e3f80e.zip
Build fix for mpqc-mpich.
Diffstat (limited to 'science')
-rw-r--r--science/mpqc/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index aa990ce9aa0c..27763b6c8390 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -71,16 +71,19 @@ CONFIGURE_ARGS+=--with-cc=${CC} \
--with-coptflags="${CFLAGS}" \
--with-cxxoptflags="${CXXFLAGS}" \
--with-f77optflags="${FFLAGS}" \
- --with-include="-I${WRKDIR} -I${LOCALBASE}/include" \
--enable-shared
.if defined(WITH_ICC)
CONFIGURE_ARGS+=--with-libs="-lsvml"
.endif
.if defined(WITH_MPICH)
CONFIGURE_ARGS+=--with-libdirs="-L${LOCALBASE}/lib -L${LOCALBASE}/mpich2/lib"\
- --with-include="-I${LOCALBASE}/mpich2/include -I${WRKDIR}" \
--enable-always-use-mpi
.endif
+.if defined(WITH_MPICH)
+CONFIGURE_ARGS+=--with-include="-I${LOCALBASE}/mpich2/include -I${WRKDIR} -I${LOCALBASE}/include"
+.else
+CONFIGURE_ARGS+=--with-include="-I${WRKDIR} -I${LOCALBASE}/include"
+.endif
MPQC_COMMAND= ${PREFIX}/bin/mpqc