aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-15 15:00:46 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-15 15:00:46 +0800
commitde8f4226f4fdba3ceab1926224838be2587163e0 (patch)
tree960a557123f230aca951d7c2f2133419f5e4e270 /science
parent01a7b31527a5764bdc03d41afd700474f47d5484 (diff)
downloadfreebsd-ports-gnome-de8f4226f4fdba3ceab1926224838be2587163e0.tar.gz
freebsd-ports-gnome-de8f4226f4fdba3ceab1926224838be2587163e0.tar.zst
freebsd-ports-gnome-de8f4226f4fdba3ceab1926224838be2587163e0.zip
- Bump PORTREVISION for science/hdf5-18 shlib change
Diffstat (limited to 'science')
-rw-r--r--science/cdo/Makefile3
-rw-r--r--science/cgnslib/Makefile3
-rw-r--r--science/ecs/Makefile4
-rw-r--r--science/fvm/Makefile4
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/hdf-java/Makefile3
-rw-r--r--science/netcdf4/Makefile3
-rw-r--r--science/py-netCDF4/Makefile3
8 files changed, 16 insertions, 11 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 12672f6d2fb5..4f843c56770a 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cdo
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= https://code.zmaw.de/attachments/download/898/ \
LOCAL/sunpoet
@@ -50,7 +51,7 @@ WITH_HDF5= yes
CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE} --with-zlib=/usr
WITH_SZIP= yes
.if (${HDF5_VER} == 18)
-LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
.else
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
.endif
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index 2e6827135fcc..19fd72e41929 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cgnslib
DISTVERSION= 2.5-5
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= SF/cgns/${PORTNAME}_${PORTVERSION:R}/Release%20${PORTVERSION:E}
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -25,7 +26,7 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
USE_LDCONFIG= yes
.if !defined(WITHOUT_HDF5)
-LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE}
PLIST_SUB= HDF5=""
.else
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index 624841278735..b92d6396c852 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ecs
PORTVERSION= 1.3.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -18,7 +18,7 @@ COMMENT= Code_Saturne Preprocessor
LIB_DEPENDS= med.2:${PORTSDIR}/french/med \
bft.1:${PORTSDIR}/science/bft \
- hdf5.6:${PORTSDIR}/science/hdf5-18 \
+ hdf5.7:${PORTSDIR}/science/hdf5-18 \
cgns.0:${PORTSDIR}/science/cgnslib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index 2a036f7d98a2..a4467f21515e 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fvm
PORTVERSION= 0.12.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -18,7 +18,7 @@ COMMENT= Code_Saturne Finite Volume Mesh
LIB_DEPENDS= med.2:${PORTSDIR}/french/med \
bft.1:${PORTSDIR}/science/bft \
- hdf5.6:${PORTSDIR}/science/hdf5-18 \
+ hdf5.7:${PORTSDIR}/science/hdf5-18 \
cgns.0:${PORTSDIR}/science/cgnslib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 4abb6023fb63..9d7f2551d298 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -63,7 +63,7 @@ CONFIGURE_ARGS+=--with-Magick=no
.endif
.if !defined(WITHOUT_HDF5)
-LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-hdf5=no
diff --git a/science/hdf-java/Makefile b/science/hdf-java/Makefile
index 93d484c40db7..63d52387c4a6 100644
--- a/science/hdf-java/Makefile
+++ b/science/hdf-java/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hdf-java
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= science java
MASTER_SITES= http://www.hdfgroup.org/ftp/HDF5/hdf-java/src/ \
http://www.predatorlabs.net/dl/
@@ -15,7 +16,7 @@ EXTRACT_SUFX= -src.tar
MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Java interface to HDF5
-LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
USE_JAVA= yes
JAVA_VERSION= 1.5+
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index b046bdebdba0..c9bdb6de3521 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netcdf
PORTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -29,7 +30,7 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
MAKE_ENV= INFODIR="${PREFIX}/${INFO_PATH}" MAKEINFOFLAGS="--no-split"
USE_GNOME= gnomehack
USE_LDCONFIG= yes
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index bb73134f75d5..48cd2a314525 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netCDF4
PORTVERSION= 0.9.4
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= http://netcdf4-python.googlecode.com/files/ \
CHEESESHOP
@@ -17,7 +18,7 @@ COMMENT= Python Interface to the NetCDF Library(versions 3 and 4)
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \
+LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18 \
netcdf.7:${PORTSDIR}/science/netcdf4
USE_PYTHON= 2.5+