aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-13 17:50:42 +0800
committeryuri <yuri@FreeBSD.org>2018-03-13 17:50:42 +0800
commit1a68de156fe719cbfb2bd1ddaa40496c5cffa2f2 (patch)
tree2a80ebb8d98b3463c3de9c5d186d55865cabee8b /science
parentee32f1eaf4309279bdfc492a9a386a4e9650062f (diff)
downloadfreebsd-ports-gnome-1a68de156fe719cbfb2bd1ddaa40496c5cffa2f2.tar.gz
freebsd-ports-gnome-1a68de156fe719cbfb2bd1ddaa40496c5cffa2f2.tar.zst
freebsd-ports-gnome-1a68de156fe719cbfb2bd1ddaa40496c5cffa2f2.zip
science/ncs: Unbreak
Port changes: * Fixed shebang in bin/code_saturne * Added stripping * Added missing LIB_DEPENDS Approved by: portmgr (port compliance, infrastructure)
Diffstat (limited to 'science')
-rw-r--r--science/ncs/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index e6a773375508..470bcb9816eb 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -13,11 +13,15 @@ COMMENT= Code_Saturne Kernel
LICENSE= GPLv2
BUILD_DEPENDS= cs_preprocess:science/ecs
-LIB_DEPENDS= libfvm.so:science/fvm \
+LIB_DEPENDS= libbft.so:science/bft \
+ libcgns.so:science/cgnslib \
+ libfvm.so:science/fvm \
+ libhdf5.so:science/hdf5 \
+ libmedC.so:french/med \
libmei.so:science/mei
-RUN_DEPENDS= xmgrace:math/grace \
- bash:shells/bash \
- xterm:x11/xterm \
+RUN_DEPENDS= xmgrace:math/grace \
+ bash:shells/bash \
+ xterm:x11/xterm \
cs_preprocess:science/ecs
USES= fortran gettext gmake iconv libtool pyqt:4 python:2.7 shebangfix
@@ -101,6 +105,8 @@ pre-everything::
@${ECHO_MSG}
post-install:
+ @cd ${STAGEDIR}${PREFIX}/lib && ${STRIP_CMD} libsaturne.so* libsyrcs.so* libsyrcs.so*
+ @${REINPLACE_CMD} -i '' -e 's|^#!.*|#!${PYTHON_CMD}|' ${STAGEDIR}${PREFIX}/bin/code_saturne
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}