aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
committermat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
commit344522393988339d341fda0818f0281645323f90 (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /science
parenta8ea83538e74965157afe830f9873190be5ac78a (diff)
downloadfreebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.tar.gz
freebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.tar.zst
freebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Diffstat (limited to 'science')
-rw-r--r--science/checkmol/Makefile2
-rw-r--r--science/medit/Makefile2
-rw-r--r--science/mol2ps/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/science/checkmol/Makefile b/science/checkmol/Makefile
index 8c6feff86a66..af0bdabeec53 100644
--- a/science/checkmol/Makefile
+++ b/science/checkmol/Makefile
@@ -17,7 +17,7 @@ NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= #
-EXTRACT_AFTER_ARGS= ${WRKDIR}
+EXTRACT_AFTER_ARGS= ${WRKSRC}
USE_FPC= yes
diff --git a/science/medit/Makefile b/science/medit/Makefile
index 9aeb51767f32..f2363ae3ec07 100644
--- a/science/medit/Makefile
+++ b/science/medit/Makefile
@@ -46,7 +46,7 @@ PLIST_FILES+= ${MESHES:S|^|%%EXAMPLESDIR%%/|}
. endif
post-extract:
- cd ${WRKDIR} && \
+ cd ${WRKSRC} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${LIBTARBALL} ${EXTRACT_AFTER_ARGS} --exclude ${MAKEFILE}
${CP} ${FILESDIR}/gttime.c ${WRKSRC}/sources/
.for l in lplib2.c lplib2.h
diff --git a/science/mol2ps/Makefile b/science/mol2ps/Makefile
index 166a4457ec57..559f53a213f8 100644
--- a/science/mol2ps/Makefile
+++ b/science/mol2ps/Makefile
@@ -19,7 +19,7 @@ NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= #
-EXTRACT_AFTER_ARGS= ${WRKDIR}
+EXTRACT_AFTER_ARGS= ${WRKSRC}
USE_FPC= yes