aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 02:41:15 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 02:41:15 +0800
commit38fe74289962f7bde8f57d9a999e61b74241ad6b (patch)
treec756810defa7862a81134a13cec391bfef55e24e /science
parentf9ace8477d074484a12cc946b59a8aab04d0810f (diff)
downloadfreebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.tar.gz
freebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.tar.zst
freebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.zip
Convert a bunch of USE_BZIP2 to USES=tar:bzip2
Approved by: portmgr (not really, but touches unstaged ports)
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile3
-rw-r--r--science/bodr/Makefile3
-rw-r--r--science/mpqc/Makefile3
-rw-r--r--science/psi3/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 056a4ec6c169..0c6b9f40564d 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -19,8 +19,7 @@ OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT=PYTHON
OPTIONS_SUB= yes
-USE_BZIP2= yes
-USES= cmake desktop-file-utils pkgconfig
+USES= cmake desktop-file-utils pkgconfig tar:bzip2
USE_GL= glu gl
USE_QT4= gui network opengl \
linguist_build moc_build qmake_build rcc_build uic_build
diff --git a/science/bodr/Makefile b/science/bodr/Makefile
index e3549ecabc0c..56071d41b954 100644
--- a/science/bodr/Makefile
+++ b/science/bodr/Makefile
@@ -13,8 +13,7 @@ BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
OPTIONS_DEFINE= DOCS
-USE_BZIP2= yes
-USES= gmake perl5
+USES= gmake perl5 tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL="${PERL}"
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index bf03925dbaf9..19b0abee5b15 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -11,9 +11,8 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= The massively parallel quantum computing library and program
GNU_CONFIGURE= yes
-USES= fortran gmake perl5
+USES= fortran gmake perl5 tar:bzip2
USE_AUTOTOOLS= autoconf
-USE_BZIP2= yes
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 6a037d6995b4..c2940f857478 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -45,9 +45,8 @@ BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= fortran gmake
+USES= fortran gmake tar:bzip2
CONFIGURE_ARGS= --with-cc=${CC} \
--with-cxx=${CXX} \
--with-fc=${FC} \