aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormisha <misha@FreeBSD.org>2017-10-30 22:45:19 +0800
committermisha <misha@FreeBSD.org>2017-10-30 22:45:19 +0800
commit4c6102e3178950815349fe5e1041aa3e93b48290 (patch)
tree42d497aa05821bedeba11400413219c84c203cab /science
parentf00e4876456c0ad891354aef0040192f12abee3c (diff)
downloadfreebsd-ports-gnome-4c6102e3178950815349fe5e1041aa3e93b48290.tar.gz
freebsd-ports-gnome-4c6102e3178950815349fe5e1041aa3e93b48290.tar.zst
freebsd-ports-gnome-4c6102e3178950815349fe5e1041aa3e93b48290.zip
- update from 1.1.0 to 1.3.0
Approved by: jpaetzel (mentor)
Diffstat (limited to 'science')
-rw-r--r--science/orthanc/Makefile13
-rw-r--r--science/orthanc/distinfo6
-rw-r--r--science/orthanc/files/patch-Core_SQLite_FunctionContext.cpp11
-rw-r--r--science/orthanc/files/patch-Core_SQLite_FunctionContext.h28
-rw-r--r--science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp11
-rw-r--r--science/orthanc/files/patch-OrthancServer_OrthancInitialization.cpp12
-rw-r--r--science/orthanc/files/patch-Resources_Configuration.json22
7 files changed, 21 insertions, 82 deletions
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 8c225c628565..d385e14fccdd 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= orthanc
-PORTVERSION= 1.1.0
-PORTREVISION= 8
+PORTVERSION= 1.3.0
CATEGORIES= science graphics net www
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/orthanc/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/:mongoose
@@ -18,6 +17,8 @@ COMMENT= RESTful DICOM server for healthcare and medical research
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: CMake: Looking for C++ include pugixml.hpp - not found
+
LIB_DEPENDS= libcurl.so:ftp/curl \
libjsoncpp.so:devel/jsoncpp \
libuuid.so:misc/e2fsprogs-libuuid \
@@ -35,8 +36,6 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libgtest.so:devel/googletest \
libpugixml.so:textproc/pugixml
-BROKEN_powerpc64= fails to configure: CMake: Looking for C++ include pugixml.hpp - not found
-
CMAKE_ARGS= -DDCMTK_LIBRARIES="dcmdsig;charls;dcmjpls" \
-DDCMTK_DIR="${LOCALBASE}" \
-DDCMTK_DICTIONARY_DIR="${LOCALBASE}/share/dcmtk" \
@@ -73,8 +72,10 @@ post-patch:
# Some tests require connections to be made to the outside world, this is
# definitely unsupported behaviour and therefor those tests are disabled with
# cmake variable above (-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=OFF).
-post-build:
- @cd ${BUILD_WRKSRC} && ./UnitTests
+#
+# Tests run is temporary disabled: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=215393
+#post-build:
+# @cd ${BUILD_WRKSRC} && ./UnitTests
post-install:
${MKDIR} ${STAGEDIR}/var/db/orthanc/db/db-v5
diff --git a/science/orthanc/distinfo b/science/orthanc/distinfo
index e116013147bb..14471b8ebf02 100644
--- a/science/orthanc/distinfo
+++ b/science/orthanc/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1469014978
-SHA256 (orthanc/Orthanc-1.1.0.tar.gz) = e8e7ce79dc327b8d0cd4917a520d867260eb58a34a2eea5e24a56db3540edbd4
-SIZE (orthanc/Orthanc-1.1.0.tar.gz) = 1152366
+TIMESTAMP = 1508149082
+SHA256 (orthanc/Orthanc-1.3.0.tar.gz) = a68b3c3fda8ea5cd065d356b314737634d8088d6ab2380c9ccfa433cc8fe61de
+SIZE (orthanc/Orthanc-1.3.0.tar.gz) = 1231636
SHA256 (orthanc/mongoose-3.8.tgz) = 6afc2c377614a01a24b78560a62d1316b29372afe08eae3715b56c877be71c6e
SIZE (orthanc/mongoose-3.8.tgz) = 1577314
diff --git a/science/orthanc/files/patch-Core_SQLite_FunctionContext.cpp b/science/orthanc/files/patch-Core_SQLite_FunctionContext.cpp
deleted file mode 100644
index 4c2b5adc3516..000000000000
--- a/science/orthanc/files/patch-Core_SQLite_FunctionContext.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Core/SQLite/FunctionContext.cpp.orig 2016-06-27 11:02:35 UTC
-+++ Core/SQLite/FunctionContext.cpp
-@@ -49,7 +49,7 @@ namespace Orthanc
- {
- FunctionContext::FunctionContext(struct sqlite3_context* context,
- int argc,
-- struct ::Mem** argv)
-+ struct sqlite3_value** argv)
- {
- assert(context != NULL);
- assert(argc >= 0);
diff --git a/science/orthanc/files/patch-Core_SQLite_FunctionContext.h b/science/orthanc/files/patch-Core_SQLite_FunctionContext.h
deleted file mode 100644
index cbbf46e2c693..000000000000
--- a/science/orthanc/files/patch-Core_SQLite_FunctionContext.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- Core/SQLite/FunctionContext.h.orig 2016-06-27 11:02:35 UTC
-+++ Core/SQLite/FunctionContext.h
-@@ -37,7 +37,7 @@
- #include "Statement.h"
-
- struct sqlite3_context;
--struct Mem; // This corresponds to the opaque type "sqlite3_value"
-+struct sqlite3_value; // This corresponds to the opaque type "sqlite3_value"
-
- namespace Orthanc
- {
-@@ -50,14 +50,14 @@ namespace Orthanc
- private:
- struct sqlite3_context* context_;
- unsigned int argc_;
-- struct ::Mem** argv_;
-+ struct sqlite3_value** argv_;
-
- void CheckIndex(unsigned int index) const;
-
- public:
- FunctionContext(struct sqlite3_context* context,
- int argc,
-- struct ::Mem** argv);
-+ struct sqlite3_value** argv);
-
- ColumnType GetColumnType(unsigned int index) const;
-
diff --git a/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp b/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp
deleted file mode 100644
index aeb0942a3991..000000000000
--- a/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- OrthancServer/FromDcmtkBridge.cpp.orig 2016-07-20 11:36:11 UTC
-+++ OrthancServer/FromDcmtkBridge.cpp
-@@ -197,7 +197,7 @@ namespace Orthanc
- LoadEmbeddedDictionary(*locker, EmbeddedResources::DICTIONARY_DICOM);
- LoadEmbeddedDictionary(*locker, EmbeddedResources::DICTIONARY_PRIVATE);
-
--#elif defined(__linux__) || defined(__FreeBSD_kernel__)
-+#elif defined(__linux__) || defined(__FreeBSD__)
- std::string path = DCMTK_DICTIONARY_DIR;
-
- const char* env = std::getenv(DCM_DICT_ENVIRONMENT_VARIABLE);
diff --git a/science/orthanc/files/patch-OrthancServer_OrthancInitialization.cpp b/science/orthanc/files/patch-OrthancServer_OrthancInitialization.cpp
deleted file mode 100644
index 6f9987a69e3f..000000000000
--- a/science/orthanc/files/patch-OrthancServer_OrthancInitialization.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- OrthancServer/OrthancInitialization.cpp.orig 2016-06-27 11:02:35 UTC
-+++ OrthancServer/OrthancInitialization.cpp
-@@ -534,7 +534,9 @@ namespace Orthanc
- #if ORTHANC_SSL_ENABLED == 1
- // Finalize OpenSSL
- // https://wiki.openssl.org/index.php/Library_Initialization#Cleanup
-+#ifdef FIPS_mode_set
- FIPS_mode_set(0);
-+#endif
- ENGINE_cleanup();
- CONF_modules_unload(1);
- EVP_cleanup();
diff --git a/science/orthanc/files/patch-Resources_Configuration.json b/science/orthanc/files/patch-Resources_Configuration.json
index 1cab6a60b0dd..e5db076ecf62 100644
--- a/science/orthanc/files/patch-Resources_Configuration.json
+++ b/science/orthanc/files/patch-Resources_Configuration.json
@@ -1,23 +1,23 @@
---- Resources/Configuration.json.orig 2015-02-12 13:47:38 UTC
+--- Resources/Configuration.json.orig 2017-07-19 11:10:48 UTC
+++ Resources/Configuration.json
-@@ -9,12 +9,12 @@
-
- // Path to the directory that holds the heavyweight files
- // (i.e. the raw DICOM instances)
+@@ -10,12 +10,12 @@
+ // Path to the directory that holds the heavyweight files (i.e. the
+ // raw DICOM instances). Backslashes must be either escaped by
+ // doubling them, or replaced by forward slashes "/".
- "StorageDirectory" : "OrthancStorage",
+ "StorageDirectory" : "/var/db/orthanc/db-v5",
- // Path to the directory that holds the SQLite index (if unset,
- // the value of StorageDirectory is used). This index could be
- // stored on a RAM-drive or a SSD device for performance reasons.
+ // Path to the directory that holds the SQLite index (if unset, the
+ // value of StorageDirectory is used). This index could be stored on
+ // a RAM-drive or a SSD device for performance reasons.
- "IndexDirectory" : "OrthancStorage",
+ "IndexDirectory" : "/var/db/orthanc/db-v5",
// Enable the transparent compression of the DICOM instances
"StorageCompression" : false,
-@@ -39,6 +39,7 @@
- // folders, in which case they will be scanned non-recursively to
- // find shared libraries.
+@@ -41,6 +41,7 @@
+ // find shared libraries. Backslashes must be either escaped by
+ // doubling them, or replaced by forward slashes "/".
"Plugins" : [
+ "%%PREFIX%%/share/orthanc/plugins/"
],