aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-12-21 08:26:58 +0800
committeryuri <yuri@FreeBSD.org>2017-12-21 08:26:58 +0800
commit58ecbe867cb10e83439d140661df0063213f4f93 (patch)
treea7b1b140598e19e63faf727bf8b335d0062f33f5 /science
parent2adb9931b0ba58b9a13e5f3477e76aac7ce1bbea (diff)
downloadfreebsd-ports-gnome-58ecbe867cb10e83439d140661df0063213f4f93.tar.gz
freebsd-ports-gnome-58ecbe867cb10e83439d140661df0063213f4f93.tar.zst
freebsd-ports-gnome-58ecbe867cb10e83439d140661df0063213f4f93.zip
e-added port: science/PETSc: Suite of data structures and routines from Argonne National Laboratory (existed 2004/11/21-2014/09/01, deleted in r366959)
Replacing the identical version committed by me as a new port in r456696. The old math/petsc port also had a slave port math/petsc-mpich that has also been deleted. Original differential revision is https://reviews.freebsd.org/D13527 Submitted by: myself Reported by: thierry that math/petsc and math/petsc-mpich existed before Approved by: adamw (mentor)
Diffstat (limited to 'science')
-rw-r--r--science/PETSc/Makefile39
-rw-r--r--science/PETSc/distinfo3
-rw-r--r--science/PETSc/files/patch-makefile11
-rw-r--r--science/PETSc/pkg-descr7
-rw-r--r--science/PETSc/pkg-plist250
5 files changed, 310 insertions, 0 deletions
diff --git a/science/PETSc/Makefile b/science/PETSc/Makefile
new file mode 100644
index 000000000000..936fe527b7ba
--- /dev/null
+++ b/science/PETSc/Makefile
@@ -0,0 +1,39 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= PETSc
+DISTVERSION= 3.8.3
+CATEGORIES= science devel
+MASTER_SITES= http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
+DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Suite of data structures and routines from Argonne National Laboratory
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libmpich.so:net/mpich2
+
+USES= blaslapack fortran gmake python shebangfix
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-shared-libraries=1 \
+ --with-mpi-dir=${LOCALBASE} \
+ CFLAGS="${CFLAGS} -msse2" CXXFLAGS="${CXXFLAGS} -msse2" CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" LIBS=""
+USE_XORG= x11
+MAKEFILE= makefile
+SHEBANG_FILES= bin/*.py bin/popup bin/saws/SAWs.py bin/saws/*.bash bin/sendToJenkins
+USE_LDCONFIG= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
+
+DATADIR= ${PREFIX}/share/${PORTNAME:tl}
+PLIST_SUB= SHLIB=${DISTVERSION} SHL=${DISTVERSION:C/\.[0-9]$//}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpetsc.so.${DISTVERSION}
+ @${FIND} ${STAGEDIR}${PREFIX} \( -name "*.html" -o -name "*.mod" \) -delete
+ @cd ${STAGEDIR}${PREFIX} && ${RM} -r bin/win32fe bin/uncrustify.cfg lib/petsc
+ @${RM} -r ${STAGEDIR}${DATADIR}/examples # examples are a mess as installed
+
+.include <bsd.port.mk>
diff --git a/science/PETSc/distinfo b/science/PETSc/distinfo
new file mode 100644
index 000000000000..e268ad0e3986
--- /dev/null
+++ b/science/PETSc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513506952
+SHA256 (petsc-3.8.3.tar.gz) = 01f9c3ed937eafac6c9e006510b61c7cd07197115ec40c429fc835f346ca3eac
+SIZE (petsc-3.8.3.tar.gz) = 27931992
diff --git a/science/PETSc/files/patch-makefile b/science/PETSc/files/patch-makefile
new file mode 100644
index 000000000000..7bf1648c0061
--- /dev/null
+++ b/science/PETSc/files/patch-makefile
@@ -0,0 +1,11 @@
+--- makefile.orig 2017-12-18 03:43:13 UTC
++++ makefile
+@@ -277,7 +277,7 @@ reconfigure:
+ @${PYTHON} ${PETSC_ARCH}/lib/petsc/conf/reconfigure-${PETSC_ARCH}.py
+ #
+ install:
+- @${PYTHON} ./config/install.py -destDir=${DESTDIR}
++ @${PYTHON} ./config/install.py -destDir=${DESTDIR}${PREFIX}
+ ${OMAKE} PETSC_ARCH=${PETSC_ARCH} PETSC_DIR=${PETSC_DIR} mpi4py-install petsc4py-install
+
+ newall:
diff --git a/science/PETSc/pkg-descr b/science/PETSc/pkg-descr
new file mode 100644
index 000000000000..b4fbcfaf59e6
--- /dev/null
+++ b/science/PETSc/pkg-descr
@@ -0,0 +1,7 @@
+A suite of data structures and routines for the scalable (parallel) solution of
+scientific applications modeled by partial differential equations. It supports
+MPI, and GPUs through CUDA or OpenCL, as well as hybrid MPI-GPU parallelism.
+PETSc (sometimes called PETSc/Tao) also contains the Tao optimization software
+library.
+
+WWW: http://www.mcs.anl.gov/petsc
diff --git a/science/PETSc/pkg-plist b/science/PETSc/pkg-plist
new file mode 100644
index 000000000000..cc25820ab5d5
--- /dev/null
+++ b/science/PETSc/pkg-plist
@@ -0,0 +1,250 @@
+bin/FASTMathInstaller.py
+bin/PetscBinaryIO.py
+bin/PetscBinaryIOTrajectory.py
+bin/PetscBinaryIO_tests.py
+bin/TOPSGenerator.py
+bin/adiforfix.py
+bin/configVars.py
+bin/parseargs.py
+bin/petsc-mpiexec.uni
+bin/petsc_conf.py
+bin/petsc_gen_xdmf.py
+bin/petscdiff
+bin/petsclogformat.py
+bin/petscmpiexec
+bin/petscnagupgrade.py
+bin/popup
+bin/portabilitycheck.py
+bin/saws/SAWs.py
+bin/saws/getSAWs.bash
+bin/saws/getStack.bash
+bin/sendToJenkins
+bin/taucc.py
+bin/update.py
+include/petsc.h
+include/petsc/finclude/petsc.h
+include/petsc/finclude/petscao.h
+include/petsc/finclude/petscbag.h
+include/petsc/finclude/petscdm.h
+include/petsc/finclude/petscdmda.h
+include/petsc/finclude/petscdmlabel.h
+include/petsc/finclude/petscdmnetwork.h
+include/petsc/finclude/petscdmplex.h
+include/petsc/finclude/petscdraw.h
+include/petsc/finclude/petscerror.h
+include/petsc/finclude/petscis.h
+include/petsc/finclude/petscksp.h
+include/petsc/finclude/petsclog.h
+include/petsc/finclude/petscmat.h
+include/petsc/finclude/petscpc.h
+include/petsc/finclude/petscsnes.h
+include/petsc/finclude/petscsnesfas.h
+include/petsc/finclude/petscsys.h
+include/petsc/finclude/petsctao.h
+include/petsc/finclude/petscts.h
+include/petsc/finclude/petscvec.h
+include/petsc/finclude/petscviewer.h
+include/petsc/mpiuni/mpi.h
+include/petsc/mpiuni/mpif.h
+include/petsc/mpiuni/mpiunifdef.h
+include/petsc/private/bagimpl.h
+include/petsc/private/characteristicimpl.h
+include/petsc/private/dmdaimpl.h
+include/petsc/private/dmforestimpl.h
+include/petsc/private/dmimpl.h
+include/petsc/private/dmlabelimpl.h
+include/petsc/private/dmmbimpl.h
+include/petsc/private/dmnetworkimpl.h
+include/petsc/private/dmpatchimpl.h
+include/petsc/private/dmpleximpl.h
+include/petsc/private/dmswarmimpl.h
+include/petsc/private/drawimpl.h
+include/petsc/private/dtimpl.h
+include/petsc/private/f90impl.h
+include/petsc/private/fortranimpl.h
+include/petsc/private/glvisvecimpl.h
+include/petsc/private/glvisviewerimpl.h
+include/petsc/private/hash.h
+include/petsc/private/isimpl.h
+include/petsc/private/kernels/blockinvert.h
+include/petsc/private/kernels/blockmatmult.h
+include/petsc/private/kernels/blocktranspose.h
+include/petsc/private/kernels/petscaxpy.h
+include/petsc/private/kspimpl.h
+include/petsc/private/linesearchimpl.h
+include/petsc/private/logimpl.h
+include/petsc/private/matimpl.h
+include/petsc/private/matorderimpl.h
+include/petsc/private/pcgamgimpl.h
+include/petsc/private/pcimpl.h
+include/petsc/private/pcmgimpl.h
+include/petsc/private/petscconvestimpl.h
+include/petsc/private/petscdsimpl.h
+include/petsc/private/petscfeimpl.h
+include/petsc/private/petscfptimpl.h
+include/petsc/private/petscfvimpl.h
+include/petsc/private/petscimpl.h
+include/petsc/private/sfimpl.h
+include/petsc/private/snesimpl.h
+include/petsc/private/taoimpl.h
+include/petsc/private/taolinesearchimpl.h
+include/petsc/private/tsimpl.h
+include/petsc/private/vecimpl.h
+include/petsc/private/viewerimpl.h
+include/petscao.h
+include/petscbag.h
+include/petscblaslapack.h
+include/petscblaslapack_mangle.h
+include/petscblaslapack_stdcall.h
+include/petscbt.h
+include/petsccharacteristic.h
+include/petscconf.h
+include/petscconfiginfo.h
+include/petscconvest.h
+include/petscctable.h
+include/petsccuda.h
+include/petsccusp.h
+include/petscdm.h
+include/petscdmcomposite.h
+include/petscdmda.h
+include/petscdmdatypes.h
+include/petscdmforest.h
+include/petscdmlabel.h
+include/petscdmmoab.h
+include/petscdmnetwork.h
+include/petscdmpatch.h
+include/petscdmplex.h
+include/petscdmredundant.h
+include/petscdmshell.h
+include/petscdmsliced.h
+include/petscdmswarm.h
+include/petscdmtypes.h
+include/petscdraw.h
+include/petscdrawtypes.h
+include/petscds.h
+include/petscdstypes.h
+include/petscdt.h
+include/petscerror.h
+include/petscfe.h
+include/petscfetypes.h
+include/petscfix.h
+include/petscfv.h
+include/petscfvtypes.h
+include/petscgll.h
+include/petscis.h
+include/petscistypes.h
+include/petscksp.h
+include/petsclog.h
+include/petscmachineinfo.h
+include/petscmat.h
+include/petscmatcoarsen.h
+include/petscmatelemental.h
+include/petscmath.h
+include/petscmathypre.h
+include/petscmatlab.h
+include/petscoptions.h
+include/petscpc.h
+include/petscpctypes.h
+include/petscpf.h
+include/petscsf.h
+include/petscsftypes.h
+include/petscsnes.h
+include/petscsys.h
+include/petsctao.h
+include/petsctaolinesearch.h
+include/petsctime.h
+include/petscts.h
+include/petscvalgrind.h
+include/petscvec.h
+include/petscversion.h
+include/petscviennacl.h
+include/petscviewer.h
+include/petscviewerhdf5.h
+include/petscviewersaws.h
+include/petscviewertypes.h
+include/petscwebclient.h
+lib/libpetsc.so
+lib/libpetsc.so.%%SHL%%
+lib/libpetsc.so.%%SHLIB%%
+libdata/pkgconfig/PETSc.pc
+%%DATADIR%%/datafiles/matrices/amesos2_test_mat0.mtx
+%%DATADIR%%/datafiles/matrices/hpd-complex-int32-float32
+%%DATADIR%%/datafiles/matrices/hpd-complex-int32-float64
+%%DATADIR%%/datafiles/matrices/hpd-complex-int64-float32
+%%DATADIR%%/datafiles/matrices/hpd-complex-int64-float64
+%%DATADIR%%/datafiles/matrices/nh-complex-int32-float32
+%%DATADIR%%/datafiles/matrices/nh-complex-int32-float64
+%%DATADIR%%/datafiles/matrices/nh-complex-int64-float32
+%%DATADIR%%/datafiles/matrices/nh-complex-int64-float64
+%%DATADIR%%/datafiles/matrices/ns-real-int32-float32
+%%DATADIR%%/datafiles/matrices/ns-real-int32-float64
+%%DATADIR%%/datafiles/matrices/ns-real-int64-float32
+%%DATADIR%%/datafiles/matrices/ns-real-int64-float64
+%%DATADIR%%/datafiles/matrices/spd-real-int32-float128
+%%DATADIR%%/datafiles/matrices/spd-real-int32-float32
+%%DATADIR%%/datafiles/matrices/spd-real-int32-float64
+%%DATADIR%%/datafiles/matrices/spd-real-int64-float32
+%%DATADIR%%/datafiles/matrices/spd-real-int64-float64
+%%DATADIR%%/datafiles/meshes/2Dgrd.exo
+%%DATADIR%%/datafiles/meshes/Rect-tri3.exo
+%%DATADIR%%/datafiles/meshes/annulus-20.exo
+%%DATADIR%%/datafiles/meshes/blockcylinder-50.exo
+%%DATADIR%%/datafiles/meshes/cow.msh
+%%DATADIR%%/datafiles/meshes/cube_5tets.cas
+%%DATADIR%%/datafiles/meshes/cube_5tets_ascii.cas
+%%DATADIR%%/datafiles/meshes/cylinder.med
+%%DATADIR%%/datafiles/meshes/doublet-tet.msh
+%%DATADIR%%/datafiles/meshes/grid_c.cgns
+%%DATADIR%%/datafiles/meshes/horse.ply.bz2
+%%DATADIR%%/datafiles/meshes/sevenside-quad-15.exo
+%%DATADIR%%/datafiles/meshes/sevenside-quad.exo
+%%DATADIR%%/datafiles/meshes/sevenside.exo
+%%DATADIR%%/datafiles/meshes/simpleblock-100.exo
+%%DATADIR%%/datafiles/meshes/square.cas
+%%DATADIR%%/datafiles/meshes/square.med
+%%DATADIR%%/datafiles/meshes/square.msh
+%%DATADIR%%/datafiles/meshes/square_bin.msh
+%%DATADIR%%/datafiles/meshes/square_bin_physnames.msh
+%%DATADIR%%/datafiles/meshes/square_quad.msh
+%%DATADIR%%/datafiles/meshes/squaremotor-30.exo
+%%DATADIR%%/datafiles/meshes/texas.msh
+%%DATADIR%%/datafiles/meshes/tut21.cgns
+%%DATADIR%%/matlab/@PetscOpenFile/PetscOpenFile.m
+%%DATADIR%%/matlab/@PetscOpenFile/close.m
+%%DATADIR%%/matlab/@PetscOpenFile/read.m
+%%DATADIR%%/matlab/@PetscOpenFile/write.m
+%%DATADIR%%/matlab/@PetscOpenSocket/PetscOpenSocket.m
+%%DATADIR%%/matlab/@PetscOpenSocket/close.m
+%%DATADIR%%/matlab/@PetscOpenSocket/read.m
+%%DATADIR%%/matlab/@PetscOpenSocket/write.m
+%%DATADIR%%/matlab/PetscBagRead.m
+%%DATADIR%%/matlab/PetscBinaryRead.m
+%%DATADIR%%/matlab/PetscBinaryWrite.m
+%%DATADIR%%/matlab/PetscReadBinaryMatlab.m
+%%DATADIR%%/matlab/PetscReadBinaryTrajectory.m
+%%DATADIR%%/matlab/UFgetPetscMat.m
+%%DATADIR%%/matlab/generatePetscTestFiles.m
+%%DATADIR%%/matlab/generatehtml.m
+%%DATADIR%%/matlab/laplacian.m
+%%DATADIR%%/matlab/laplacianlicense.txt
+%%DATADIR%%/matlab/launch.m
+%%DATADIR%%/saws/documentation
+%%DATADIR%%/saws/images/arrow.png
+%%DATADIR%%/saws/images/transition.bmp
+%%DATADIR%%/saws/js/PETSc.js
+%%DATADIR%%/saws/js/boxTree.js
+%%DATADIR%%/saws/js/defaults.js
+%%DATADIR%%/saws/js/drawDiagrams.js
+%%DATADIR%%/saws/js/events.js
+%%DATADIR%%/saws/js/getCmdOptions.js
+%%DATADIR%%/saws/js/listLogic.js
+%%DATADIR%%/saws/js/main.js
+%%DATADIR%%/saws/js/matrixTex.js
+%%DATADIR%%/saws/js/parsePrefix.js
+%%DATADIR%%/saws/js/populateLists.js
+%%DATADIR%%/saws/js/recordSawsData.js
+%%DATADIR%%/saws/js/tree.js
+%%DATADIR%%/saws/js/treeInterface.js
+%%DATADIR%%/saws/js/utils.js
+%%DATADIR%%/saws/readme
+%%DATADIR%%/xml/performance_xml2html.xsl