aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-02-04 21:37:15 +0800
committertcberner <tcberner@FreeBSD.org>2017-02-04 21:37:15 +0800
commit614efcf540e295f5c397c15efa09c57cf6f129d1 (patch)
treed3572a824910587e038d1100b5972b19f37005aa /science
parent456af42702b83f7d7a579791394af005ff85204e (diff)
downloadfreebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.tar.gz
freebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.tar.zst
freebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.zip
Switch ports to use USE_PYQT=<foo> instead of using RUN_- and BUILD_DEPENDS
pyqt.mk provides USE_PYQT=<list> to depend on its components. Convert the ports not yet using it to it. Reviewed by: rakuco, mat Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9261
Diffstat (limited to 'science')
-rw-r--r--science/ncs/Makefile6
-rw-r--r--science/veusz/Makefile7
2 files changed, 6 insertions, 7 deletions
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index 02162ae4c6b2..3dd9bd85d673 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -12,8 +12,7 @@ COMMENT= Code_Saturne Kernel
LICENSE= GPLv2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=0:devel/py-qt4 \
- cs_preprocess:science/ecs \
+BUILD_DEPENDS= cs_preprocess:science/ecs \
pyrcc4:textproc/py-qt4-xml
LIB_DEPENDS= libfvm.so:science/fvm \
libmei.so:science/mei
@@ -22,8 +21,9 @@ RUN_DEPENDS= xmgrace:math/grace \
xterm:x11/xterm \
cs_preprocess:science/ecs
-USES= fortran gettext gmake iconv libtool python shebangfix
+USES= fortran gettext gmake iconv libtool pyqt:4 python shebangfix
USE_GNOME= libxml2
+USE_PYQT= core
SHEBANG_FILES= bin/runcase.in
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
GNU_CONFIGURE= yes
diff --git a/science/veusz/Makefile b/science/veusz/Makefile
index 1ce5962234f3..ddc7a200ce2f 100644
--- a/science/veusz/Makefile
+++ b/science/veusz/Makefile
@@ -12,12 +12,11 @@ COMMENT= Scientific plotting package
LICENSE= GPLv2
-RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}qt4-svg>0:graphics/py-qt4-svg
+RUN_DEPENDS= ${PYNUMPY}
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= python
+USES= pyqt:4 python
+USE_PYQT= gui svg
USE_PYTHON= distutils autoplist
post-patch: