aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-04-13 07:58:02 +0800
committerdanilo <danilo@FreeBSD.org>2014-04-13 07:58:02 +0800
commit6ef00b3d5ab06ddce423b07863375e3c128f1482 (patch)
tree7e8a8f79508e1c199c7c917e6812b741491f08a0 /science
parent374ab1324fe6b03cccacb2497ccac1c6f244e144 (diff)
downloadfreebsd-ports-gnome-6ef00b3d5ab06ddce423b07863375e3c128f1482.tar.gz
freebsd-ports-gnome-6ef00b3d5ab06ddce423b07863375e3c128f1482.tar.zst
freebsd-ports-gnome-6ef00b3d5ab06ddce423b07863375e3c128f1482.zip
- Support staging
- Convert LIB_DEPENDS to new syntax Approved by: portmgr (blanket)
Diffstat (limited to 'science')
-rw-r--r--science/fvcom-mpi/Makefile3
-rw-r--r--science/fvcom/Makefile11
2 files changed, 6 insertions, 8 deletions
diff --git a/science/fvcom-mpi/Makefile b/science/fvcom-mpi/Makefile
index ec384ff66b7d..1ff483e939a0 100644
--- a/science/fvcom-mpi/Makefile
+++ b/science/fvcom-mpi/Makefile
@@ -5,12 +5,11 @@ PKGNAMESUFFIX= -mpi
MAINTAINER= jwbacon@tds.net
-LIB_DEPENDS+= mpi:${PORTSDIR}/net/openmpi
+LIB_DEPENDS+= libmpi.so:${PORTSDIR}/net/openmpi
MASTERDIR= ${.CURDIR}/../fvcom
MAKE_ARGS+= FC=${LOCALBASE}/mpi/openmpi/bin/mpif90 \
PORT_CPP_FLAGS+=-DMULTIPROCESSOR
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/science/fvcom/Makefile b/science/fvcom/Makefile
index 67a6dc513a8a..93a4b3899680 100644
--- a/science/fvcom/Makefile
+++ b/science/fvcom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvcom
PORTVERSION= 2.7.1
-PORTREVISION= 2
+PORTREVISION?= 2
CATEGORIES= science
MASTER_SITES= http://fvcom.smast.umassd.edu/FVCOM/index.html/
DISTNAME= sourcecode1
@@ -13,9 +13,9 @@ MAINTAINER= jwbacon@tds.net
COMMENT= Unstructured Grid Finite Volume Coastal Ocean Model
# Check netcdf lib for Fortran support!
-LIB_DEPENDS+= netcdff:${PORTSDIR}/science/netcdf-ftn \
- lapack:${PORTSDIR}/math/lapack \
- blas:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libnetcdff.so:${PORTSDIR}/science/netcdf-ftn \
+ liblapack.so:${PORTSDIR}/math/lapack \
+ libblas.so:${PORTSDIR}/math/lapack
USES= fortran
WRKSRC= ${WRKDIR}/FVCOM2.7.1/FVCOM_source
@@ -24,7 +24,6 @@ PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}
RESTRICTED= may not be redistributed because of licensing reasons
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTFILES})
@@ -42,6 +41,6 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fvcom \
- ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.post.mk>