aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2018-01-22 02:21:55 +0800
committergerald <gerald@FreeBSD.org>2018-01-22 02:21:55 +0800
commit71efda459be3afb794501a625517fbc8ef1baf47 (patch)
treeb6b3a1047bd32df38eb8683a4f7b97f4cc8e5153 /science
parentf1e093e811d99a19b9cab8ec35e049a8a0db91c1 (diff)
downloadfreebsd-ports-gnome-71efda459be3afb794501a625517fbc8ef1baf47.tar.gz
freebsd-ports-gnome-71efda459be3afb794501a625517fbc8ef1baf47.tar.zst
freebsd-ports-gnome-71efda459be3afb794501a625517fbc8ef1baf47.zip
Fix the build on FreeBSD 12+ by using a current version of GCC which
is already used by some of the dependencies. This avoids build errors of the following kind: /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc6/libgfortran.so.3 not found Submitted by: maintainer (Rainer Hurling <rhurlin@gwdg.de>) PR: 225230
Diffstat (limited to 'science')
-rw-r--r--science/mpb/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 5e6e96fe9f12..a36d60d06c80 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -33,6 +33,10 @@ NLOPT_LIB_DEPENDS= libnlopt.so:math/nlopt
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200051
+USE_GCC= yes
+.endif
+
.if ${PORT_OPTIONS:MATLAS}
LIB_DEPENDS+= libatlas.so:math/atlas
CONFIGURE_ARGS+= --with-lapack=-lalapack