aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
commitc07b3d06f74c2b1f5144739f606ea2f60e5c4125 (patch)
tree75bc18c02ad45658df6e53d5864baec96c002730 /science
parent980b4f867dba0a997b3f1336459072e6da844359 (diff)
downloadfreebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.gz
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.zst
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.zip
Switch autoconf dependencies from 2.53 or 2.59 to 2.61.
PR: ports/116639 Submitted by: aDe
Diffstat (limited to 'science')
-rw-r--r--science/abinit/Makefile6
-rw-r--r--science/chemtool/Makefile4
-rw-r--r--science/elmer-fem/Makefile3
-rw-r--r--science/elmer-hutiter/Makefile3
-rw-r--r--science/libghemical/Makefile4
-rw-r--r--science/mbdyn/Makefile4
-rw-r--r--science/mpqc/Makefile8
-rw-r--r--science/psi3/Makefile4
8 files changed, 21 insertions, 15 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 204259e294a0..bede38f2bb31 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= abinit
PORTVERSION= 5.2.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_LOCAL:S|%SUBDIR%|maho/abinit|} \
ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PORTVERSION}/
@@ -18,7 +19,7 @@ USE_FORTRAN= yes
CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= GNU_HOST=${GNU_HOST}
@@ -38,6 +39,9 @@ BLAS= -lblas
LAPACK= -llapack
.endif
+pre-configure:
+ @(cd ${WRKSRC} && config/scripts/makemake)
+
test:
cd ${WRKSRC}/tests ; ${GMAKE} tests
diff --git a/science/chemtool/Makefile b/science/chemtool/Makefile
index b94261ae118e..e3467f63370e 100644
--- a/science/chemtool/Makefile
+++ b/science/chemtool/Makefile
@@ -6,7 +6,7 @@
PORTNAME= chemtool
PORTVERSION= 1.6.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
@@ -17,7 +17,7 @@ RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
USE_GNOME= gtk20
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/science/elmer-fem/Makefile b/science/elmer-fem/Makefile
index a43e83e69704..79c7546ff312 100644
--- a/science/elmer-fem/Makefile
+++ b/science/elmer-fem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fem
PORTVERSION= 5.3.2
+PORTREVISION= 1
CATEGORIES= science tk84
MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/src/
PKGNAMEPREFIX= elmer-
@@ -27,7 +28,7 @@ USE_FORTRAN= yes
FCFLAGS+= -O3 -ffast-math
.endif
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET=
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
index d22df4ed2c9c..00d6bf8bbb39 100644
--- a/science/elmer-hutiter/Makefile
+++ b/science/elmer-hutiter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hutiter
PORTVERSION= 5.3.2
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/src/
PKGNAMEPREFIX= elmer-
@@ -38,7 +39,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|' -e 's|%%FC%%|${FC}|' ${WRKSRC}/configure.in
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
CONFIGURE_ENV+= FC=${FC} F77=${FC}
ALL_TARGET=
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 4fa2c85c7efe..7288f97a69d5 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -6,7 +6,7 @@
PORTNAME= libghemical
PORTVERSION= 2.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://www.uku.fi/~thassine/projects/download/ \
http://bioinformatics.org/ghemical/download/
@@ -46,7 +46,7 @@ LAPACK= -llapack
CONFIGURE_ARGS+= --enable-mopac7 --enable-mpqc --enable-openbabel --with-blas="-L${LOCALBASE}/lib ${BLAS}" -with-lapack="-L${LOCALBASE}/lib ${LAPACK}"
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
.include <bsd.port.post.mk>
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index eb7b63405c7d..88f695820802 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mbdyn
PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://mbdyn.aero.polimi.it/~masarati/Download/mbdyn/
@@ -17,7 +17,7 @@ COMMENT= A MultiBody Dynamics analysis system
LIB_DEPENDS= umfpack:${PORTSDIR}/math/suitesparse
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
USE_GMAKE= yes
CONFIGURE_ARGS+= --program-prefix='' --with-umfpack=yes
CPPFLAGS+= -I${LOCALBASE}/include/suitesparse ${PTHREAD_CFLAGS}
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index b56f7622c219..7ca8eefbcb61 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science parallel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mpqc
@@ -19,7 +19,6 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
-PLIST_SUB+= VERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
@@ -48,7 +47,7 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
.endif
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
USE_FORTRAN= yes
@@ -68,7 +67,8 @@ CONFIGURE_ARGS+=--with-cc=${CC} \
--with-coptflags="${CFLAGS}" \
--with-cxxoptflags="${CXXFLAGS}" \
--with-f77optflags="${FFLAGS}" \
- --enable-shared
+ --enable-shared \
+ --with-sc-datadir=${PREFIX}/share/mpqc/${PORTVERSION}
.if defined(WITH_ICC)
CONFIGURE_ARGS+=--with-libs="-lsvml"
.endif
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 5db9f1ac2a19..9a1f99663c41 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= psi3
PORTVERSION= 3.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= psicode
@@ -38,7 +38,7 @@ LAPACK= -llapack
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
WANT_FORTRAN=yes #dummy but future use
BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42