aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-06 23:54:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-06 23:54:48 +0800
commit65a97d02386e20d7e2e919afe9d43dd08f53e404 (patch)
tree5690e7dfa7773b6113c6e701d8d420fd36a3b991 /science
parentbcec20f4d70545e879ba4966bbc89e658ea0065a (diff)
downloadfreebsd-ports-gnome-65a97d02386e20d7e2e919afe9d43dd08f53e404.tar.gz
freebsd-ports-gnome-65a97d02386e20d7e2e919afe9d43dd08f53e404.tar.zst
freebsd-ports-gnome-65a97d02386e20d7e2e919afe9d43dd08f53e404.zip
This plugin extends the RESTful API of Orthanc with WADO and DICOMweb
support. WWW: http://www.orthanc-server.com/ PR: 202816 Submitted by: mp39590@gmail.com
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/orthanc-dicomweb/Makefile45
-rw-r--r--science/orthanc-dicomweb/distinfo2
-rw-r--r--science/orthanc-dicomweb/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index d6f8d88c890b..41dd309850d1 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -98,6 +98,7 @@
SUBDIR += openbabel
SUBDIR += openkim
SUBDIR += orthanc
+ SUBDIR += orthanc-dicomweb
SUBDIR += orthanc-postgresql
SUBDIR += orthanc-webviewer
SUBDIR += p5-Algorithm-SVMLight
diff --git a/science/orthanc-dicomweb/Makefile b/science/orthanc-dicomweb/Makefile
new file mode 100644
index 000000000000..89665791f513
--- /dev/null
+++ b/science/orthanc-dicomweb/Makefile
@@ -0,0 +1,45 @@
+# Created by: mp39590@gmail.com
+# $FreeBSD$
+
+PORTNAME= orthanc-dicomweb
+PORTVERSION= 0.1
+CATEGORIES= science net
+MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/plugin-dicom-web/
+DISTNAME= OrthancDicomWeb-${PORTVERSION}
+DIST_SUBDIR= orthanc
+
+MAINTAINER= mp39590@gmail.com
+COMMENT= WADO and DICOMweb support for Orthanc
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/orthanc/OrthancCPlugin.h:${PORTSDIR}/science/orthanc \
+ gtest-config:${PORTSDIR}/devel/googletest
+LIB_DEPENDS= libgdcmCommon.so:${PORTSDIR}/devel/gdcm \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libboost_locale.so:${PORTSDIR}/devel/boost-libs \
+ libjsoncpp.so:${PORTSDIR}/devel/jsoncpp \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libpugixml.so:${PORTSDIR}/textproc/pugixml
+
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USES= cmake:outsource python:build
+WRKSRC= ${WRKDIR}/OrthancDicomWeb-${PORTVERSION}
+
+PLIST_FILES= share/orthanc/plugins/libOrthancDicomWeb.so \
+ share/orthanc/plugins/libOrthancDicomWeb.so.${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Orthanc/Resources/CMake/*.cmake
+
+do-test:
+ @cd ${BUILD_WRKSRC} && ./UnitTests
+
+.include <bsd.port.mk>
diff --git a/science/orthanc-dicomweb/distinfo b/science/orthanc-dicomweb/distinfo
new file mode 100644
index 000000000000..09ead81ea416
--- /dev/null
+++ b/science/orthanc-dicomweb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (orthanc/OrthancDicomWeb-0.1.tar.gz) = c9f1a7c2873b157b434947d6b0bffe2d92cc94f5678c170b05bd702b969617f7
+SIZE (orthanc/OrthancDicomWeb-0.1.tar.gz) = 112788
diff --git a/science/orthanc-dicomweb/pkg-descr b/science/orthanc-dicomweb/pkg-descr
new file mode 100644
index 000000000000..3d1936f55270
--- /dev/null
+++ b/science/orthanc-dicomweb/pkg-descr
@@ -0,0 +1,4 @@
+This plugin extends the RESTful API of Orthanc with WADO and DICOMweb
+support.
+
+WWW: http://www.orthanc-server.com/