aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-04-13 08:09:13 +0800
committerdanilo <danilo@FreeBSD.org>2014-04-13 08:09:13 +0800
commit5e018b3010cc37d2fc6f3548ab1cd3c8f5f76b98 (patch)
tree875f8136e52f5cff043ef5c1d931cca212276862 /science
parenta14c5acc33ecff6b9ec6bba05d736d1c235f65a6 (diff)
downloadfreebsd-ports-gnome-5e018b3010cc37d2fc6f3548ab1cd3c8f5f76b98.tar.gz
freebsd-ports-gnome-5e018b3010cc37d2fc6f3548ab1cd3c8f5f76b98.tar.zst
freebsd-ports-gnome-5e018b3010cc37d2fc6f3548ab1cd3c8f5f76b98.zip
- Support staging
- Convert LIB_DEPENDS to new syntax Approved by: portmgr (blanket)
Diffstat (limited to 'science')
-rw-r--r--science/meep/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
index 058b72a5a0ae..51054e9eda2b 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -13,10 +13,10 @@ COMMENT= FDTD simulation software to model electromagnetic systems
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash \
harminv:${PORTSDIR}/science/harminv \
gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile \
- blas.2:${PORTSDIR}/math/blas \
- ctl.5:${PORTSDIR}/science/libctl \
- hdf5.7:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS+= libguile.so:${PORTSDIR}/lang/guile \
+ libblas.so:${PORTSDIR}/math/blas \
+ libctl.so:${PORTSDIR}/science/libctl \
+ libhdf5.so:${PORTSDIR}/science/hdf5-18
RUN_DEPENDS+= harminv:${PORTSDIR}/science/harminv
GNU_CONFIGURE= yes
@@ -32,7 +32,6 @@ OPTIONS_DEFINE= OPENMPI
OPTIONS_DEFAULT= OPENMPI
OPENMPI_DESC= MPI support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENMPI}
@@ -40,6 +39,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+=--with-mpi
CONFIGURE_ENV+= MPICXX=${LOCALBASE}/mpi/openmpi/bin/mpiCC
+CFLAGS+= -I${LOCALBASE}/mpi/openmpi/include
PLIST_SUB+= MPI="" NOMPI="@comment "
.else
CONFIGURE_ARGS+=--without-mpi