aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-03-20 04:51:14 +0800
committerthierry <thierry@FreeBSD.org>2006-03-20 04:51:14 +0800
commitc34fd3a7389f9dce36472aa0c13e6b0ee2008e23 (patch)
tree4a3088077cd77e945d90cac211641cf64ff13275 /science
parent33cdb278304ae5202cb85b1c91313d227f7c3196 (diff)
downloadfreebsd-ports-gnome-c34fd3a7389f9dce36472aa0c13e6b0ee2008e23.tar.gz
freebsd-ports-gnome-c34fd3a7389f9dce36472aa0c13e6b0ee2008e23.tar.zst
freebsd-ports-gnome-c34fd3a7389f9dce36472aa0c13e6b0ee2008e23.zip
A program for doing calculation on Smith Chart, similar in functionality to
xsmc but with a simpler user interface; written with GNU/GTK library and released under GNU/GPL. Written by Lapo Pieri IK5NAX WWW: http://www.qsl.net/ik5nax PR: ports/93224 Submitted by: Diane Bruce <db (at) db.net> - VA3DB
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/gsmc/Makefile24
-rw-r--r--science/gsmc/distinfo3
-rw-r--r--science/gsmc/files/patch-draw.c18
-rw-r--r--science/gsmc/pkg-descr8
5 files changed, 54 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index de203bf9b26b..448171f2abc3 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -32,6 +32,7 @@
SUBDIR += gnudatalanguage
SUBDIR += gramps
SUBDIR += gromacs
+ SUBDIR += gsmc
SUBDIR += gsystem
SUBDIR += hdf
SUBDIR += hdf5
diff --git a/science/gsmc/Makefile b/science/gsmc/Makefile
new file mode 100644
index 000000000000..c0c1f90af254
--- /dev/null
+++ b/science/gsmc/Makefile
@@ -0,0 +1,24 @@
+# ports collection makefile for: gsmc
+# Date created: 11 February 2006
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsmc
+PORTVERSION= 1.0
+CATEGORIES= science hamradio
+MASTER_SITES= http://www.qsl.net/ik5nax/
+
+MAINTAINER= db@db.net
+COMMENT= Smith chart program for impedance matching
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= gsmc.1
+PLIST_FILES= bin/gsmc
+
+.include <bsd.port.mk>
diff --git a/science/gsmc/distinfo b/science/gsmc/distinfo
new file mode 100644
index 000000000000..79f12c040fb7
--- /dev/null
+++ b/science/gsmc/distinfo
@@ -0,0 +1,3 @@
+MD5 (gsmc-1.0.tar.gz) = 62c8dfef5fda9ecb52ee656ff3559a79
+SHA256 (gsmc-1.0.tar.gz) = 59386860b15d921375f2a254c92f0264dee23642d66fb864fea4940471690c59
+SIZE (gsmc-1.0.tar.gz) = 77095
diff --git a/science/gsmc/files/patch-draw.c b/science/gsmc/files/patch-draw.c
new file mode 100644
index 000000000000..def213b74fa0
--- /dev/null
+++ b/science/gsmc/files/patch-draw.c
@@ -0,0 +1,18 @@
+--- draw.c.orig Sat Feb 11 12:42:26 2006
++++ draw.c Sat Feb 11 12:42:59 2006
+@@ -576,6 +576,7 @@
+ break;
+
+ default:
++ break;
+ }
+
+ }
+@@ -591,6 +592,7 @@
+ case 'o': strcpy(rv, "op"); break;
+ case 'c': strcpy(rv, "sp"); break;
+ default:
++ break;
+ }
+
+ }
diff --git a/science/gsmc/pkg-descr b/science/gsmc/pkg-descr
new file mode 100644
index 000000000000..fa195ef9c180
--- /dev/null
+++ b/science/gsmc/pkg-descr
@@ -0,0 +1,8 @@
+A program for doing calculation on Smith Chart, similar in functionality to
+xsmc but with a simpler user interface; written with GNU/GTK library and
+released under GNU/GPL. Written by Lapo Pieri IK5NAX
+
+WWW: http://www.qsl.net/ik5nax
+
+- Diane Bruce, VA3DB
+db@db.net