aboutsummaryrefslogtreecommitdiffstats
path: root/security/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-04-05 01:18:16 +0800
committermarino <marino@FreeBSD.org>2016-04-05 01:18:16 +0800
commitb8300e3db20b3a23e8bc2b0d768392e923f0aa7c (patch)
tree3f8879b0e0f9baac1b5f27d53c7d19686efbe48f /security/Makefile
parentb1a0d1be2f45874447153f21329cbc8b0fcfab1c (diff)
downloadfreebsd-ports-gnome-b8300e3db20b3a23e8bc2b0d768392e923f0aa7c.tar.gz
freebsd-ports-gnome-b8300e3db20b3a23e8bc2b0d768392e923f0aa7c.tar.zst
freebsd-ports-gnome-b8300e3db20b3a23e8bc2b0d768392e923f0aa7c.zip
Add new port security/libadacrypt
This is a crypto library for Ada with a nice API and is written for the i386 and x86_64 hardware architecture. Symmetric cryptography supported: * Blockciphers: AES, Twofish, 3DES, Serpent * Hash functions: SHA-1, SHA-256, SHA-384, SHA-512, Whirlpool * MACs: RMAC, HMAC, CMAC * Modes of operation: BPS, CFB, Ctr, OFB * Authenticated Encryption Schemes: OCB, SIV, McOE Assymmetric cryptography supported: * DSA signature scheme * OEAP-RSA * ECDSA, ECDH Unsigned big number library features: * Primary cyclic group arithmetic (Z_p) * Binary Field arithmetic support * Elliptic Curve arithmetic
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 08dcf19de561..8a9d039d8e2c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -289,6 +289,7 @@
SUBDIR += lasso
SUBDIR += lastpass-cli
SUBDIR += letsencrypt.sh
+ SUBDIR += libadacrypt
SUBDIR += libassuan
SUBDIR += libbeid
SUBDIR += libbf