aboutsummaryrefslogtreecommitdiffstats
path: root/security/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-07-28 18:32:17 +0800
committergarga <garga@FreeBSD.org>2005-07-28 18:32:17 +0800
commitf960b4bc52d26a543e37752c455d49f1df26e5b0 (patch)
tree2c93f86b687f35d5d3ab55852a4bf0200a10cfe7 /security/Makefile
parent871a63eba0f0a0ac8d5c19fde82d1fd714fc425a (diff)
downloadfreebsd-ports-gnome-f960b4bc52d26a543e37752c455d49f1df26e5b0.tar.gz
freebsd-ports-gnome-f960b4bc52d26a543e37752c455d49f1df26e5b0.tar.zst
freebsd-ports-gnome-f960b4bc52d26a543e37752c455d49f1df26e5b0.zip
This package implements an algorithm for breaking the PkZip cipher that was
devised by Eli Biham and Paul Kocher. This program applies a known plaintext attack to an encrypted file. A known-plaintext-attack recovers a password using the encrypted file and (part of) the unencrypted file. Please note that cryptographers use the word 'plaintext' for any kind of unencrypted data - not necessarily readable ASCII text. Before you ask why somebody may want to know the password when he already knows the plaintext think of the following situations: - Usually there's a large number of files in a ZIP-archive. Usually all these files are encrypted using the same password. So if you know one of the files, you can recover the password and decrypt the other files. - You need to know only a part of the plaintext (at least 13 bytes). Many files have commonly known headers, like DOS .EXE-files. Knowing a reasonably long header you can recover the password and decrypt the entire file. WWW: http://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack.html PR: ports/84192 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3ca0bd665723..e3c3865f4e2e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -393,6 +393,7 @@
SUBDIR += pinentry-gtk
SUBDIR += pinentry-gtk2
SUBDIR += pinentry-qt
+ SUBDIR += pkcrack
SUBDIR += pks
SUBDIR += pktsuckers
SUBDIR += poc