aboutsummaryrefslogtreecommitdiffstats
path: root/security/R-cran-digest
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-09-04 21:01:29 +0800
committertota <tota@FreeBSD.org>2011-09-04 21:01:29 +0800
commit592018be9a4daf0817f6675118e575b19caa08b6 (patch)
treefc79835739cea281e640cde4011922ded1a2f792 /security/R-cran-digest
parent8c8e15e36d9ceddd980c25a7a42b181770a2cb60 (diff)
downloadfreebsd-ports-gnome-592018be9a4daf0817f6675118e575b19caa08b6.tar.gz
freebsd-ports-gnome-592018be9a4daf0817f6675118e575b19caa08b6.tar.zst
freebsd-ports-gnome-592018be9a4daf0817f6675118e575b19caa08b6.zip
- Add a new port: security/R-cran-digest
The digest package provides a function 'digest' for the creation of hash digests of arbitrary R objects (using the md5, sha-1, sha-256 and crc32 algorithms) permitting easy comparison of R language objects, as well as a function hmac() to create hash-based message authentication code. The md5 algorithm by Ron Rivest is specified in RFC 1321, the SHA-1 and SHA-256 algorithms are specified in FIPS-180-1 and FIPS-180-2, and the crc32 algorithm is described in ftp://ftp.rocksoft.com/cliens/rocksoft/papers/crc_v3.txt. For md5, sha-1 and sha-256, this packages uses small standalone implementations that were provided by Christophe Devine. For crc32, code from the zlib library is used. Please note that this package is not meant to be deployed for cryptographic purposes for which more comprehensive (and widely tested) libraries such as OpenSSL should be used. WWW: http://cran.r-project.org/web/packages/digest/
Diffstat (limited to 'security/R-cran-digest')
-rw-r--r--security/R-cran-digest/Makefile22
-rw-r--r--security/R-cran-digest/distinfo2
-rw-r--r--security/R-cran-digest/pkg-descr15
3 files changed, 39 insertions, 0 deletions
diff --git a/security/R-cran-digest/Makefile b/security/R-cran-digest/Makefile
new file mode 100644
index 000000000000..93504daddf12
--- /dev/null
+++ b/security/R-cran-digest/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: R-cran-digest
+# Date created: 2011-09-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= digest
+PORTVERSION= 0.5.0
+CATEGORIES= security
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Create cryptographic hash digests of R objects
+
+LICENSE= GPLv2
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/R-cran-digest/distinfo b/security/R-cran-digest/distinfo
new file mode 100644
index 000000000000..8589b421b274
--- /dev/null
+++ b/security/R-cran-digest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (digest_0.5.0.tar.gz) = cc5429653b927e29682f9da6c9ede12121f940019eaf6e876f85cea844915478
+SIZE (digest_0.5.0.tar.gz) = 40061
diff --git a/security/R-cran-digest/pkg-descr b/security/R-cran-digest/pkg-descr
new file mode 100644
index 000000000000..1590b496d1ec
--- /dev/null
+++ b/security/R-cran-digest/pkg-descr
@@ -0,0 +1,15 @@
+The digest package provides a function 'digest' for the creation
+of hash digests of arbitrary R objects (using the md5, sha-1, sha-256
+and crc32 algorithms) permitting easy comparison of R language
+objects, as well as a function hmac() to create hash-based message
+authentication code. The md5 algorithm by Ron Rivest is specified
+in RFC 1321, the SHA-1 and SHA-256 algorithms are specified in
+FIPS-180-1 and FIPS-180-2, and the crc32 algorithm is described in
+ftp://ftp.rocksoft.com/cliens/rocksoft/papers/crc_v3.txt. For md5,
+sha-1 and sha-256, this packages uses small standalone implementations
+that were provided by Christophe Devine. For crc32, code from the
+zlib library is used. Please note that this package is not meant
+to be deployed for cryptographic purposes for which more comprehensive
+(and widely tested) libraries such as OpenSSL should be used.
+
+WWW: http://cran.r-project.org/web/packages/digest/