aboutsummaryrefslogtreecommitdiffstats
path: root/security/acid/files
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2000-09-26 10:58:04 +0800
committerfoxfair <foxfair@FreeBSD.org>2000-09-26 10:58:04 +0800
commite1da7eace1cbb81bd3e0b53b0228fc31569d34ba (patch)
tree61b117441db470d68af769ef2fd2ad0eb82c0f55 /security/acid/files
parent7ef8e8fcf402dff840497d5db5c2288882c90c5d (diff)
downloadfreebsd-ports-gnome-e1da7eace1cbb81bd3e0b53b0228fc31569d34ba.tar.gz
freebsd-ports-gnome-e1da7eace1cbb81bd3e0b53b0228fc31569d34ba.tar.zst
freebsd-ports-gnome-e1da7eace1cbb81bd3e0b53b0228fc31569d34ba.zip
Add acid to our ports tree. (not out, sorry)
This is acid v0.9.4, Analysis Console for Intrusion Databases (ACID) with Snort and MySQL. Before someone complain about it, I need to say portlint doesn't like this port so much. That's because the naming rule of DISTFILES(from the author) has a bad style. ACID needs snort 1.6.3(maybe higher) and php3/mysql, we are waitng for upgrading the development version of snort to make this port happy. Submitted by: Yen-Ming Chen <yenming.chen@foundstone.com>
Diffstat (limited to 'security/acid/files')
-rw-r--r--security/acid/files/Makefile.acid32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/acid/files/Makefile.acid b/security/acid/files/Makefile.acid
new file mode 100644
index 000000000000..b1ef1a723531
--- /dev/null
+++ b/security/acid/files/Makefile.acid
@@ -0,0 +1,32 @@
+# This is a dummy Makefile for FreeBSD ports system, not from the author.
+# We don't need to compile anything but just copy these files to finish
+# the installation.
+#
+# Foxfair. <foxfair@FreeBSD.org>
+ACIDDIR=/usr/local/share/doc/apache/acid
+INSTALL=install
+
+ACIDFILES=\
+ README \
+ acid_common.php \
+ acid_conf.php \
+ acid_footer.html \
+ acid_hdr1.html \
+ acid_hdr2.html \
+ acid_main.php \
+ acid_pkt_form.php \
+ acid_pkt_main.php \
+ acid_pkt_sqlcalls.php \
+ acid_stat_alerts.php \
+ acid_stat_common.php \
+ acid_stat_time.php \
+ acid_style.css \
+ index.html
+
+all: install
+
+install: ${ACIDFILES}
+ [ -d ${ACIDDIR} ] || mkdir ${ACIDDIR}
+ for i in ${ACIDFILES}; do \
+ ${INSTALL} -c -m 444 $$i ${ACIDDIR} ; \
+ done