aboutsummaryrefslogtreecommitdiffstats
path: root/security/aide
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2005-04-22 09:14:57 +0800
committercy <cy@FreeBSD.org>2005-04-22 09:14:57 +0800
commit341c52773202e8aa07f93a4198a6513c88b78066 (patch)
treeab551bef6587ae914c60713a68046b08dd41a8d3 /security/aide
parent4b4bf51a6c37596ab9c14f24ac36140ce1ab0ec5 (diff)
downloadfreebsd-ports-gnome-341c52773202e8aa07f93a4198a6513c88b78066.tar.gz
freebsd-ports-gnome-341c52773202e8aa07f93a4198a6513c88b78066.tar.zst
freebsd-ports-gnome-341c52773202e8aa07f93a4198a6513c88b78066.zip
- Package list fixes
- aide.conf moved from /var/db/aide to PREFIX/etc
Diffstat (limited to 'security/aide')
-rw-r--r--security/aide/Makefile12
-rw-r--r--security/aide/files/patch-doc_aide.18
-rw-r--r--security/aide/pkg-descr2
-rw-r--r--security/aide/pkg-message10
-rw-r--r--security/aide/pkg-plist16
5 files changed, 26 insertions, 22 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index 2693ba1499c8..c53d4a62a100 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aide
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITE_SOURCEFORGE+= http://unc.dl.sourceforge.net/%SUBDIR%/ \
http://umn.dl.sourceforge.net/%SUBDIR%/ \
@@ -27,14 +28,12 @@ COMMENT= A replacement and extension for Tripwire
LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
-BROKEN= "Incomplete pkg-plist (installs files into nonstandard locale directory)"
-
USE_GMAKE= yes
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-mhash \
--with-zlib \
- --with-config_file=/var/db/aide/aide.conf
+ --with-config_file=${PREFIX}/etc/aide.conf
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -43,8 +42,11 @@ MAN5= aide.conf.5
post-install:
@${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
- @${MKDIR} /var/db/aide/databases
- @if [ ! -f /var/db/aide/aide.conf ]; then \
+ @if [ ! -d ${PREFIX}/etc/aide.conf ]; then \
+ ${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf ; \
+ fi
+ @if [ ! -d /var/db/aide/databases ]; then \
+ ${MKDIR} -p /var/db/aide/databases; \
${CHOWN} root:wheel /var/db/aide ; \
${CHOWN} root:wheel /var/db/aide/databases ; \
${CHMOD} 0700 /var/db/aide ; \
diff --git a/security/aide/files/patch-doc_aide.1 b/security/aide/files/patch-doc_aide.1
index b016612768a3..f063b3e85387 100644
--- a/security/aide/files/patch-doc_aide.1
+++ b/security/aide/files/patch-doc_aide.1
@@ -6,18 +6,18 @@
.SH FILES
-.B <prefix>/etc/aide.conf
+.TP
-+.BI PREFIX/etc/aide.conf.sample
++.BI <prefix>/etc/aide.conf.sample
+Example aide configuration file.
+.TP
-+.BI /var/adm/aide/aide.conf
++.BI <prefix>/etc/aide.conf
Default aide configuration file.
-.B <prefix>/etc/aide.db
+.TP
-+.BI /var/adm/aide/databases/aide.db
++.BI /var/db/aide/databases/aide.db
Default aide database.
-.B <prefix>/etc/aide.db.new
+.TP
-+.BI /var/adm/aide/databases/aide.db.new
++.BI /var/db/aide/databases/aide.db.new
Default aide output database.
.SH SEE ALSO
.BR aide.conf (5)
diff --git a/security/aide/pkg-descr b/security/aide/pkg-descr
index 763edb21255f..7341e9a098de 100644
--- a/security/aide/pkg-descr
+++ b/security/aide/pkg-descr
@@ -2,5 +2,5 @@ AIDE is Advanced Intrusion Detection Environment.
This piece of software was written as a replacement and extension
for Tripwire.
-WWW: http://aide.sourceforge.net
+WWW: ttp://sourceforge.net/projects/aide
Author: rammer@cs.tut.fi
diff --git a/security/aide/pkg-message b/security/aide/pkg-message
index bb458031cfde..6fbea62fbd4f 100644
--- a/security/aide/pkg-message
+++ b/security/aide/pkg-message
@@ -1,10 +1,12 @@
-If you want to finish setting up AIDE, don't forget to create your own
-aide.conf based on ${PREFIX}/etc/aide.conf.sample and then copy it to
-the /var/db/aide/ directory. You will also need to run the following
-commands:
+If you want to finish setting up AIDE, don't forget to customise your
+own aide.conf in ${PREFIX}/etc/aide.conf. You will also need to run
+the following commands:
cd /var/db/aide
aide --init
mv databases/aide.db.new databases/aide.db
You may want to change the permissions of the /var/adm/aide/ directory tree.
+
+For your reference, a copy of the original aide.conf is supplied in
+${PREFIX}/etc/aide.conf.sample.
diff --git a/security/aide/pkg-plist b/security/aide/pkg-plist
index 83b0bfee2521..27bc6451f5fe 100644
--- a/security/aide/pkg-plist
+++ b/security/aide/pkg-plist
@@ -1,10 +1,10 @@
bin/aide
etc/aide.conf.sample
-@exec /bin/mkdir -p /var/adm/aide/databases
-@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/adm/aide
-@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/adm/aide/databases
-@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/adm/aide
-@exec [ -f /var/adm/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/adm/aide/databases
-@unexec rmdir /var/adm/aide/databases 2>/dev/null || true
-@unexec rmdir /var/adm/aide 2>/dev/null || true
-@unexec rmdir /var/adm 2>/dev/null || true
+@exec /bin/mkdir -p /var/db/aide/databases
+@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/db/aide
+@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/db/aide/databases
+@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/db/aide
+@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chmod 0700 /var/db/aide/databases
+@unexec rmdir /var/db/aide/databases 2>/dev/null || true
+@unexec rmdir /var/db/aide 2>/dev/null || true
+@unexec rmdir /var/db 2>/dev/null || true