aboutsummaryrefslogtreecommitdiffstats
path: root/security/amavisd-new
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-09-10 22:05:50 +0800
committererwin <erwin@FreeBSD.org>2006-09-10 22:05:50 +0800
commit911d8684f79a7c43bb29ca257002e456bf4f8a8a (patch)
tree5128287346b4ff56433ae56379185a12c4eaa738 /security/amavisd-new
parent59a6fa42ff542f391477f03932be441edc65ceda (diff)
downloadfreebsd-ports-gnome-911d8684f79a7c43bb29ca257002e456bf4f8a8a.tar.gz
freebsd-ports-gnome-911d8684f79a7c43bb29ca257002e456bf4f8a8a.tar.zst
freebsd-ports-gnome-911d8684f79a7c43bb29ca257002e456bf4f8a8a.zip
Big rework:
- Register some dependencies directly that were installed by another dependencies before - Add BerkeleyDB to OPTIONS for nanny/cache/snmp, it is not a mandatory dependency any more - Add SQLite to OPTIONS for lookups/logging/quarantine - Add SASL to OPTIONS for authentication - Add SpamAssassin to OPTIONS, it is not a mandatory dependency any more - Add p0f (passive OS fingerprinting) to OPTIONS and an rc.d script for p0fanalyzer - Add file to OPTIONS to use ports' file(1) instead of system file(1) - Add nomarch and cabextract to OPTIONS, they are not mandatory any more - Provide some alternatives for archiver dependencies (rar/unrar, arj/unar, etc.) - Cleanup deprecated PLIST_SUB and pkg-plist entries - Use reinplace editing instead of patches where possible - Ensure that the config file is installed with proper attributes - Add some p0f explanation to pkg-message - Style PR: 102944 Submitted by: Gabor Kovesdan <gkovesdan@t-hosting.hu> (maintainer)
Diffstat (limited to 'security/amavisd-new')
-rw-r--r--security/amavisd-new/Makefile177
-rw-r--r--security/amavisd-new/files/patch-amavisd22
-rw-r--r--security/amavisd-new/files/patch-amavisd-agent11
-rw-r--r--security/amavisd-new/files/patch-amavisd-nanny11
-rw-r--r--security/amavisd-new/files/patch-amavisd.conf22
-rw-r--r--security/amavisd-new/files/patch-amavisd.conf-sample40
-rw-r--r--security/amavisd-new/files/patch-config.h.in11
-rw-r--r--security/amavisd-new/files/pkg-message.in12
-rw-r--r--security/amavisd-new/pkg-plist3
9 files changed, 152 insertions, 157 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 13288d8cd3c9..b29bdae80547 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,7 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.4.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -20,7 +20,7 @@ MAINTAINER= gkovesdan@t-hosting.hu
COMMENT= Performance-enhanced daemonized version of amavis-perl
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
- ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/${PERL_ARCH}/Convert/UUlib.pm:${PORTSDIR}/converters/p5-Convert-UUlib \
@@ -29,13 +29,15 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Un
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
- ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
- ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB \
- ${LOCALBASE}/bin/cabextract:${PORTSDIR}/archivers/cabextract \
- ${LOCALBASE}/bin/rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
+ ${SITE_PERL}/IO/Wrap.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server
USE_PERL5_RUN= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-user=${AMAVISUSER} --with-runtime-dir=${AMAVISDIR}
+CONFIGURE_WRKSRC= ${WRKSRC}/helper-progs
+BUILD_WRKSRC= ${WRKSRC}/helper-progs
AMAVISUSER?= vscan
AMAVISGROUP?= vscan
@@ -44,26 +46,42 @@ AMAVISQUARANTINE?= /var/virusmails
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.p.+//}
-OPTIONS= MYSQL "MySQL support" off \
- PGSQL "PgSQL support" off \
- LDAP "LDAP support" off \
- MILTER "sendmail milter support" on \
- RAR "rar support" on \
- ARJ "arj support" on \
- LHA "lha support" on \
- ARC "arc support" on \
- ZOO "zoo support with zoo archiver" on \
- UNZOO "zoo support with unzoo archiver" off \
- LZOP "lzop support" on \
- FREEZE "freeze support" on
+OPTIONS= BDB "Use BerkeleyDB for nanny/cache/snmp" on \
+ SQLITE "Use SQLite for lookups/logging/quarantine" off \
+ MYSQL "Use MySQL for lookups/logging/quarantine" off \
+ PGSQL "Use PgSQL for lookups/logging/quarantine" off \
+ LDAP "Use LDAP for lookups" off \
+ SASL "Use SASL authentication" off \
+ MILTER "Sendmail milter support" on \
+ NEW_MILTER "New sendmail milter support (external module)" off \
+ SPAMASSASSIN "Use mail/p5-Mail-SpamAssassin" on \
+ P0F "Passive operating system fingerprinting" off \
+ FILE "Use newer file(1) utility from ports" off \
+ RAR "RAR support with archivers/rar" off \
+ UNRAR "RAR support with archivers/unrar" on \
+ ARJ "ARJ support with archivers/arj" on \
+ UNARJ "ARJ support with archivers/unarj" off \
+ LHA "LHA support with archivers/lha" on \
+ ARC "ARC support with archivers/arc" on \
+ NOMARCH "ARC support with archivers/nomarch" off \
+ CAB "CAB support with archivers/cabextract" on \
+ RPM "RPM support with archivers/rpm2cpio" on \
+ ZOO "ZOO support with archivers/zoo" on \
+ UNZOO "ZOO support with archivers/unzoo" off \
+ LZOP "LZOP support with archivers/lzop" on \
+ FREEZE "FREEZE support with archivers/freeze" on \
+ TNEF "Add external tnef decoder converters/tnef" off
SUB_FILES= pkg-install pkg-deinstall pkg-message
-SUB_LIST= AMAVISUSER=${AMAVISUSER} \
+SUB_LIST+= AMAVISUSER=${AMAVISUSER} \
AMAVISGROUP=${AMAVISGROUP} \
AMAVISDIR=${AMAVISDIR} \
- AMAVISQUARANTINE=${AMAVISQUARANTINE} \
- DOCSDIR=${DOCSDIR}
+ AMAVISQUARANTINE=${AMAVISQUARANTINE}
+
+PLIST_SUB+= AMAVIS_NOAMAVIS=${AMAVIS_NOAMAVIS} \
+ AMAVIS_NOMILTER=${AMAVIS_NOMILTER} \
+ AMAVIS_NOP0F=${AMAVIS_NOP0F}
.include <bsd.port.pre.mk>
@@ -79,22 +97,13 @@ USE_RC_SUBR+= amavis-milter.sh
AMAVIS_NOMILTER="@comment "
.endif
-PLIST_SUB+= AMAVIS_NOMILTER=${AMAVIS_NOMILTER} \
- AMAVIS_NOAMAVIS=${AMAVIS_NOAMAVIS} \
- RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
-
-.if defined(AMAVIS_NOAMAVIS)
-do-build:
- @${ECHO} libmilter not available, not building amavis-milter and amavis
-.else
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-user=${AMAVISUSER} --with-runtime-dir=${AMAVISDIR}
-CONFIGURE_WRKSRC= ${WRKSRC}/helper-progs
-BUILD_WRKSRC= ${WRKSRC}/helper-progs
+.if defined(WITH_BDB)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
.endif
-SED_SCRIPT= ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/}
+.if defined(WITH_SQLITE)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+.endif
.if defined(WITH_MYSQL)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
@@ -108,7 +117,34 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
RUN_DEPENDS+= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
.endif
+.if defined(WITH_SASL)
+RUN_DEPENDS+= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+.endif
+
+.if defined(WITH_NEW_MILTER)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/amavisd-milter:${PORTSDIR}/security/amavisd-milter
+.endif
+
+.if defined(WITH_SPAMASSASSIN)
+RUN_DEPENDS+= ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+.endif
+
+.if defined(WITH_P0F)
+RUN_DEPENDS+= ${LOCALBASE}/bin/p0f:${PORTSDIR}/net-mgmt/p0f
+USE_RC_SUBR+= p0fanalyzer.sh
+.else
+AMAVIS_NOP0F= "@comment "
+.endif
+
+.if defined(WITH_FILE)
+RUN_DEPENDS+= ${LOCALBASE}/bin/file:${PORTSDIR}/sysutils/file
+.endif
+
.if defined(WITH_RAR)
+RUN_DEPENDS+= ${LOCALBASE}/bin/rar:${PORTSDIR}/archivers/rar
+.endif
+
+.if defined(WITH_UNRAR)
RUN_DEPENDS+= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar
.endif
@@ -116,6 +152,10 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar
RUN_DEPENDS+= ${LOCALBASE}/bin/arj:${PORTSDIR}/archivers/arj
.endif
+.if defined(WITH_UNARJ)
+RUN_DEPENDS+= ${LOCALBASE}/bin/unarj:${PORTSDIR}/archivers/unarj
+.endif
+
.if defined(WITH_LHA)
RUN_DEPENDS+= ${LOCALBASE}/bin/lha:${PORTSDIR}/archivers/lha
.endif
@@ -124,6 +164,18 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/lha:${PORTSDIR}/archivers/lha
RUN_DEPENDS+= ${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc
.endif
+.if defined(WITH_NOMARCH)
+RUN_DEPENDS+= ${LOCALBASE}/bin/nomarch:${PORTSDIR}/archivers/nomarch
+.endif
+
+.if defined(WITH_CAB)
+RUN_DEPENDS+= ${LOCALBASE}/bin/cabextract:${PORTSDIR}/archivers/cabextract
+.endif
+
+.if defined(WITH_RPM)
+RUN_DEPENDS+= ${LOCALBASE}/bin/rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
+.endif
+
.if defined(WITH_ZOO)
RUN_DEPENDS+= ${LOCALBASE}/bin/zoo:${PORTSDIR}/archivers/zoo
.endif
@@ -140,10 +192,35 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/lzop:${PORTSDIR}/archivers/lzop
RUN_DEPENDS+= ${LOCALBASE}/bin/unfreeze:${PORTSDIR}/archivers/freeze
.endif
+.if defined(WITH_TNEF)
+RUN_DEPENDS+= ${LOCALBASE}/bin/tnef:${PORTSDIR}/converters/tnef
+.endif
+
post-patch:
.for f in amavisd.conf amavisd.conf-sample amavisd amavisd-agent amavisd-nanny amavisd-release
- @${REINPLACE_CMD} ${SED_SCRIPT} -e "s@'zoo'\]@['zoo','unzoo'] ]@" ${WRKSRC}/${f}
+ @${REINPLACE_CMD} "s@'zoo'\]@['zoo','unzoo'] ]@" ${WRKSRC}/${f}
+.endfor
+.for i in amavisd.conf amavisd.conf-sample
+ @${REINPLACE_CMD} -e "s|$daemon_user = \'vscan\';|$daemon_user = \'${AMAVISUSER}\';|" \
+ -e "s|$daemon_group = \'vscan\';|$daemon_group = \'${AMAVISGROUP}\';|" \
+ -e "s|/var/amavis|${AMAVISDIR}|" \
+ -e "s|/var/lib/amavis|${AMAVISDIR}|" \
+ -e 's|$$log_level = 2;|$$log_level = 0;|' \
+ -e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
+ ${WRKSRC}/${i}
.endfor
+ @${REINPLACE_CMD} "s|/var/amavis/db|${AMAVISDIR}/db|" ${WRKSRC}/amavisd-agent
+ @${REINPLACE_CMD} "s|/var/amavis/db|${AMAVISDIR}/db|" ${WRKSRC}/amavisd-nanny
+ @${REINPLACE_CMD} "s|#define HAVE_MKTEMP|#undef HAVE_MKTEMP|" \
+ ${WRKSRC}/helper-progs/config.h.in
+ @${REINPLACE_CMD} "s|/etc/amavisd.conf|${PREFIX}/etc/amavisd.conf|" \
+ ${WRKSRC}/amavisd
+
+.if defined(AMAVIS_NOAMAVIS)
+do-configure:
+do-build:
+ @${ECHO} libmilter not available, not building amavis-milter and amavis
+.endif
pre-install:
@${SH} ${PKGINSTALL} ${DISTNAME} PRE-INSTALL
@@ -155,21 +232,27 @@ do-install:
.if !defined(AMAVIS_NOMILTER)
${INSTALL_PROGRAM} ${WRKSRC}/helper-progs/amavis-milter ${PREFIX}/sbin
.endif
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd-agent ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd-nanny ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd-release ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf ${PREFIX}/etc/amavisd.conf-dist
-.if !exists(${PREFIX}/etc/amavisd.conf)
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf ${PREFIX}/etc
+.if defined(WITH_P0F)
+ ${INSTALL_SCRIPT} ${WRKSRC}/p0f-analyzer.pl ${PREFIX}/sbin
.endif
+.for i in amavisd amavisd-agent amavisd-nanny amavisd-release
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/sbin
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf ${PREFIX}/etc/amavisd.conf-dist
${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf-sample ${PREFIX}/etc/amavisd.conf-sample
${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf-default ${PREFIX}/etc/amavisd.conf-default
+.if !exists(${PREFIX}/etc/amavisd.conf)
+#
+# This can contain sensitive information, e.g. SQL passwords, so it should be handled
+# with care.
+#
+ ${INSTALL} -o root -g ${AMAVISGROUP} -m 640 ${WRKSRC}/amavisd.conf ${PREFIX}/etc
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-. for FILE in AAAREADME.first INSTALL LDAP.schema LICENSE RELEASE_NOTES README_FILES/*
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-. endfor
+.for i in AAAREADME.first INSTALL LDAP.schema LICENSE RELEASE_NOTES README_FILES/*
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
.endif
post-install:
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index da766985392c..22cf6d322974 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,14 +1,5 @@
---- amavisd.orig Tue Jun 27 13:31:56 2006
-+++ amavisd Mon Jul 31 00:44:09 2006
-@@ -9335,7 +9335,7 @@
- Amavis::Conf::build_default_maps();
-
- # default location of the config file if none specified
--push(@config_files, '/etc/amavisd.conf') if !@config_files;
-+push(@config_files, '%%PREFIX%%/etc/amavisd.conf') if !@config_files;
- # Read/execute the config file, which may override default settings
- Amavis::Conf::read_config(@config_files);
-
+--- amavisd.old Fri Aug 18 13:01:43 2006
++++ amavisd Fri Aug 18 13:01:51 2006
@@ -12049,15 +12049,20 @@
my($bounced) = $msginfo->dsn_sent;
for my $r (@{$msginfo->per_recip_data}) {
@@ -38,3 +29,12 @@
$self->smtp_resp(0, $resp);
}
}
+@@ -15055,6 +15060,8 @@
+ local_tests_only => $sa_local_tests_only,
+ home_dir_for_helpers => $helpers_home,
+ stop_at_threshold => 0,
++ LOCAL_STATE_DIR => '/var/lib',
++ PREFIX => '/usr/local',
+ # DEF_RULES_DIR => '/usr/local/share/spamassassin',
+ # LOCAL_RULES_DIR => '/etc/mail/spamassassin',
+ #see man Mail::SpamAssassin for other options
diff --git a/security/amavisd-new/files/patch-amavisd-agent b/security/amavisd-new/files/patch-amavisd-agent
deleted file mode 100644
index c73160b1af3d..000000000000
--- a/security/amavisd-new/files/patch-amavisd-agent
+++ /dev/null
@@ -1,11 +0,0 @@
---- amavisd-agent.orig Sun Jun 19 18:26:43 2005
-+++ amavisd-agent Sun Jun 19 18:28:04 2005
-@@ -107,7 +107,7 @@
- # main program starts here
- $SIG{INT} = sub { die "\n" }; # do the END code block
- my($env) = BerkeleyDB::Env->new(
-- '-Home'=>'/var/amavis/db', '-Flags'=> DB_INIT_CDB | DB_INIT_MPOOL);
-+ '-Home'=>'%%AMAVISDIR%%/db', '-Flags'=> DB_INIT_CDB | DB_INIT_MPOOL);
- defined $env or die "BDB no env: $BerkeleyDB::Error $!";
- my($db) = BerkeleyDB::Hash->new(
- '-Filename'=>'snmp.db', '-Flags'=>DB_RDONLY, '-Env'=>$env );
diff --git a/security/amavisd-new/files/patch-amavisd-nanny b/security/amavisd-new/files/patch-amavisd-nanny
deleted file mode 100644
index 034e500bf983..000000000000
--- a/security/amavisd-new/files/patch-amavisd-nanny
+++ /dev/null
@@ -1,11 +0,0 @@
---- amavisd-nanny.orig Tue Aug 24 16:34:51 2004
-+++ amavisd-nanny Wed Aug 25 12:42:23 2004
-@@ -52,7 +52,7 @@
- my($activettl) = 10*60; # stuck active children are sent a SIGTERM after this
- # many seconds
-
--my($db_home) = '/var/amavis/db'; # DB databases directory
-+my($db_home) = '%%AMAVISDIR%%/db'; # DB databases directory
- my($dbfile) = 'nanny.db';
- my($wakeuptime) = 2; # seconds
-
diff --git a/security/amavisd-new/files/patch-amavisd.conf b/security/amavisd-new/files/patch-amavisd.conf
deleted file mode 100644
index 936086e47d71..000000000000
--- a/security/amavisd-new/files/patch-amavisd.conf
+++ /dev/null
@@ -1,22 +0,0 @@
---- amavisd.conf.orig Tue Jul 4 11:13:34 2006
-+++ amavisd.conf Tue Jul 4 11:17:15 2006
-@@ -14,15 +14,15 @@
- # @bypass_spam_checks_maps = (1); # uncomment to DISABLE anti-spam code
-
- $max_servers = 2; # num of pre-forked children (2..15 is common), -m
--$daemon_user = 'vscan'; # (no default; customary: vscan or amavis), -u
--$daemon_group = 'vscan'; # (no default; customary: vscan or amavis), -g
-+$daemon_user = '%%AMAVISUSER%%'; # (no default; customary: vscan or amavis), -u
-+$daemon_group = '%%AMAVISGROUP%%'; # (no default; customary: vscan or amavis), -g
-
- $mydomain = 'example.com'; # a convenient default for other settings
-
--# $MYHOME = '/var/amavis'; # a convenient default for other settings, -H
-+# $MYHOME = '%%AMAVISDIR%%'; # a convenient default for other settings, -H
- $TEMPBASE = "$MYHOME/tmp"; # working directory, needs to exist, -T
- $ENV{TMPDIR} = $TEMPBASE; # environment variable TMPDIR
--$QUARANTINEDIR = '/var/virusmails'; # -Q
-+$QUARANTINEDIR = '%%AMAVISQUARANTINE%%'; # -Q
- # $quarantine_subdir_levels = 1; # add level of subdirs to disperse quarantine
-
- # $daemon_chroot_dir = $MYHOME; # chroot directory or undef, -R
diff --git a/security/amavisd-new/files/patch-amavisd.conf-sample b/security/amavisd-new/files/patch-amavisd.conf-sample
deleted file mode 100644
index 998561a9ea28..000000000000
--- a/security/amavisd-new/files/patch-amavisd.conf-sample
+++ /dev/null
@@ -1,40 +0,0 @@
---- amavisd.conf-sample.orig Tue Jul 4 11:06:53 2006
-+++ amavisd.conf-sample Tue Jul 4 11:09:07 2006
-@@ -63,7 +63,7 @@
- # $MYHOME serves as a quick default for some other configuration settings.
- # More refined control is available with each individual setting further down.
- # $MYHOME is not used directly by the program. No trailing slash!
--#$MYHOME = '/var/lib/amavis'; # (default is '/var/amavis'), -H
-+#$MYHOME = '%%AMAVISDIR%%'; # (default is '/var/amavis'), -H
-
- # $mydomain serves as a quick default for some other configuration settings.
- # More refined control is available with each individual setting further down.
-@@ -74,8 +74,8 @@
-
- # Set the user and group to which the daemon will change if started as root
- # (otherwise just keeps the UID unchanged, and these settings have no effect):
--$daemon_user = 'vscan'; # (no default; customary: vscan or amavis), -u
--$daemon_group = 'vscan'; # (no default; customary: vscan or amavis), -g
-+$daemon_user = '%%AMAVISUSER%%'; # (no default; customary: vscan or amavis), -u
-+$daemon_group = '%%AMAVISGROUP%%'; # (no default; customary: vscan or amavis), -g
-
- # Runtime working directory (cwd), and a place where
- # temporary directories for unpacking mail are created.
-@@ -310,7 +310,7 @@
- # 3: server, client
- # 4: decompose parts
- # 5: more debug details
--$log_level = 2; # (defaults to 0), -d
-+$log_level = 0; # (defaults to 0), -d
-
- # Customizable template for the most interesting log file entry (e.g. with
- # $log_level=0) (take care to properly quote Perl special characters like '\')
-@@ -684,7 +684,7 @@
- # or a directory (no trailing slash)
- # (the default value is undef, meaning no quarantine)
- #
--$QUARANTINEDIR = '/var/virusmails'; # -Q
-+$QUARANTINEDIR = '%%AMAVISQUARANTINE%%'; # -Q
-
- #$quarantine_subdir_levels = 1; # add level of subdirs to disperse quarantine
-
diff --git a/security/amavisd-new/files/patch-config.h.in b/security/amavisd-new/files/patch-config.h.in
deleted file mode 100644
index 63559836a5d2..000000000000
--- a/security/amavisd-new/files/patch-config.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- helper-progs/config.h.in.orig Mon Mar 6 00:26:08 2006
-+++ helper-progs/config.h.in Tue Apr 4 08:21:29 2006
-@@ -17,7 +17,7 @@
- #define HAVE_MKDTEMP
-
- /* Define if you have the mktemp function, undefine otherwise */
--#define HAVE_MKTEMP
-+#undef HAVE_MKTEMP
-
- /* Define if we have the snprintf function, undefine otherwise */
- #define HAVE_SNPRINTF
diff --git a/security/amavisd-new/files/pkg-message.in b/security/amavisd-new/files/pkg-message.in
index 8900f7083713..db1db5290888 100644
--- a/security/amavisd-new/files/pkg-message.in
+++ b/security/amavisd-new/files/pkg-message.in
@@ -13,11 +13,19 @@
amavisd_enable="YES"
- If you want to use the amavis sendmail milter interface,
- you need the following additional line in /etc/rc.conf
+ If you have installed and want to use the amavis sendmail milter interface,
+ you need the following additional line in /etc/rc.conf:
amavis_milter_enable="YES"
+ If you have installed and want to use the p0fanalyzer interface,
+ you need the following additional lines in /etc/rc.conf
+ (with modifications according to your needs):
+
+ amavisd_p0fanalyzer_enable="YES"
+ amavisd_p0fanalyzer_p0f_interface='bge0'
+ amavisd_p0fanalyzer_p0f_filter='tcp dst port 25'
+
Configuration templates are available in %%PREFIX%%/etc
as amavisd.conf-dist, amavisd.conf-sample and amavisd.conf-default.
Documentation is available in %%DOCSDIR%%.
diff --git a/security/amavisd-new/pkg-plist b/security/amavisd-new/pkg-plist
index a9bf1d758682..a7693e599dc0 100644
--- a/security/amavisd-new/pkg-plist
+++ b/security/amavisd-new/pkg-plist
@@ -1,6 +1,4 @@
@comment $FreeBSD$
-%%AMAVIS_NOMILTER%%@unexec %%RC_DIR%%/amavis-milter%%RC_SUFX%% stop > /dev/null 2>&1 || true
-@unexec %%RC_DIR%%/amavisd%%RC_SUFX%% stop > /dev/null 2>&1 || true
%%PORTDOCS%%%%DOCSDIR%%/AAAREADME.first
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LDAP.schema
@@ -39,6 +37,7 @@ etc/amavisd.conf-dist
etc/amavisd.conf-sample
%%AMAVIS_NOAMAVIS%%sbin/amavis
%%AMAVIS_NOMILTER%%sbin/amavis-milter
+%%AMAVIS_NOP0F%%sbin/p0f-analyzer.pl
sbin/amavisd
sbin/amavisd-agent
sbin/amavisd-nanny