aboutsummaryrefslogtreecommitdiffstats
path: root/security/aolserver-nsopenssl/Makefile
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-02 22:09:36 +0800
committergabor <gabor@FreeBSD.org>2007-02-02 22:09:36 +0800
commitdcc6448ae99e39a3672156982f7e05d981460d27 (patch)
tree12bffc5f264fa6cc519efd5953b2f5be30a93e4d /security/aolserver-nsopenssl/Makefile
parentacfc8a371e282842cb25a98bff9f05337171d0c8 (diff)
downloadfreebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.tar.gz
freebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.tar.zst
freebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.zip
An AOLserver socket driver module which implements SSL/TLS encryption on
incomming sockets, and also adds an https client API. WWW: http://www.aolserver.com/ - Martin Matuska martin@matuska.org PR: ports/105781 Submitted by: Martin Matuska <martin@matuska.org> Approved by: erwin (mentor)
Diffstat (limited to 'security/aolserver-nsopenssl/Makefile')
-rw-r--r--security/aolserver-nsopenssl/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/aolserver-nsopenssl/Makefile b/security/aolserver-nsopenssl/Makefile
new file mode 100644
index 000000000000..a2143d9b608b
--- /dev/null
+++ b/security/aolserver-nsopenssl/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: aolserver-nsopenssl
+# Date created: 12 Oct 2006
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aolserver-nsopenssl
+PORTVERSION= 3.0.b26
+CATEGORIES= security www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aolserver
+DISTFILES= nsopenssl-3.0beta26-src.tar.gz
+DIST_SUBDIR= aolserver
+
+MAINTAINER= martin@matuska.org
+COMMENT= OpenSSL socket encryption module for AOLserver
+
+WRKSRC= ${WRKDIR}/nsopenssl-3.0beta26
+
+AOLSERVERBASE?= ${PREFIX}/aolserver
+BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+
+USE_OPENSSL= yes
+USE_GMAKE= yes
+
+MAKE_ARGS= AOLSERVER=${AOLSERVERBASE} OPENSSL=${OPENSSLBASE}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog README TODO
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>