aboutsummaryrefslogtreecommitdiffstats
path: root/security/aolserver-nsopenssl
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-02 22:09:36 +0800
committergabor <gabor@FreeBSD.org>2007-02-02 22:09:36 +0800
commitdcc6448ae99e39a3672156982f7e05d981460d27 (patch)
tree12bffc5f264fa6cc519efd5953b2f5be30a93e4d /security/aolserver-nsopenssl
parentacfc8a371e282842cb25a98bff9f05337171d0c8 (diff)
downloadfreebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.tar.gz
freebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.tar.zst
freebsd-ports-gnome-dcc6448ae99e39a3672156982f7e05d981460d27.zip
An AOLserver socket driver module which implements SSL/TLS encryption on
incomming sockets, and also adds an https client API. WWW: http://www.aolserver.com/ - Martin Matuska martin@matuska.org PR: ports/105781 Submitted by: Martin Matuska <martin@matuska.org> Approved by: erwin (mentor)
Diffstat (limited to 'security/aolserver-nsopenssl')
-rw-r--r--security/aolserver-nsopenssl/Makefile43
-rw-r--r--security/aolserver-nsopenssl/distinfo3
-rw-r--r--security/aolserver-nsopenssl/pkg-descr7
-rw-r--r--security/aolserver-nsopenssl/pkg-plist4
4 files changed, 57 insertions, 0 deletions
diff --git a/security/aolserver-nsopenssl/Makefile b/security/aolserver-nsopenssl/Makefile
new file mode 100644
index 000000000000..a2143d9b608b
--- /dev/null
+++ b/security/aolserver-nsopenssl/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: aolserver-nsopenssl
+# Date created: 12 Oct 2006
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aolserver-nsopenssl
+PORTVERSION= 3.0.b26
+CATEGORIES= security www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aolserver
+DISTFILES= nsopenssl-3.0beta26-src.tar.gz
+DIST_SUBDIR= aolserver
+
+MAINTAINER= martin@matuska.org
+COMMENT= OpenSSL socket encryption module for AOLserver
+
+WRKSRC= ${WRKDIR}/nsopenssl-3.0beta26
+
+AOLSERVERBASE?= ${PREFIX}/aolserver
+BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+
+USE_OPENSSL= yes
+USE_GMAKE= yes
+
+MAKE_ARGS= AOLSERVER=${AOLSERVERBASE} OPENSSL=${OPENSSLBASE}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog README TODO
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/aolserver-nsopenssl/distinfo b/security/aolserver-nsopenssl/distinfo
new file mode 100644
index 000000000000..033f1b17e8a8
--- /dev/null
+++ b/security/aolserver-nsopenssl/distinfo
@@ -0,0 +1,3 @@
+SIZE (aolserver/nsopenssl-3.0beta26-src.tar.gz) = 71367
+MD5 (aolserver/nsopenssl-3.0beta26-src.tar.gz) = ab35addeee1df8f38028807b4a45dbd4
+SHA256 (aolserver/nsopenssl-3.0beta26-src.tar.gz) = 4284e9dbfc82c23030a025d8c5de3e3b373530af29e4d20dafd0eb6e03e358cd
diff --git a/security/aolserver-nsopenssl/pkg-descr b/security/aolserver-nsopenssl/pkg-descr
new file mode 100644
index 000000000000..e91a2ba3655e
--- /dev/null
+++ b/security/aolserver-nsopenssl/pkg-descr
@@ -0,0 +1,7 @@
+An AOLserver socket driver module which implements SSL/TLS encryption on
+incomming sockets, and also adds an https client API.
+
+WWW: http://www.aolserver.com/
+
+- Martin Matuska
+martin@matuska.org
diff --git a/security/aolserver-nsopenssl/pkg-plist b/security/aolserver-nsopenssl/pkg-plist
new file mode 100644
index 000000000000..e2d4e112bcb9
--- /dev/null
+++ b/security/aolserver-nsopenssl/pkg-plist
@@ -0,0 +1,4 @@
+%%AOLSERVERBASE%%/bin/nsopenssl.so
+%%AOLSERVERBASE%%/lib/libnsopenssl.a
+%%AOLSERVERBASE%%/lib/libnsopenssl.so
+%%AOLSERVERBASE%%/modules/tcl/https.tcl