aboutsummaryrefslogtreecommitdiffstats
path: root/security/apache-xml-security-c/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-02-15 07:10:27 +0800
committerrafan <rafan@FreeBSD.org>2007-02-15 07:10:27 +0800
commit147ed15977008fd17fb9bfe5a491baaa99248954 (patch)
tree9bd7bf6bc60d9b0e92ba7e23c8dc4fc584f6c472 /security/apache-xml-security-c/Makefile
parent1ffd97a5976f293d7700949c92b3e35c109bed53 (diff)
downloadfreebsd-ports-gnome-147ed15977008fd17fb9bfe5a491baaa99248954.tar.gz
freebsd-ports-gnome-147ed15977008fd17fb9bfe5a491baaa99248954.tar.zst
freebsd-ports-gnome-147ed15977008fd17fb9bfe5a491baaa99248954.zip
Add apache-xml-security-c 1.3.1, apache XML security libraries C
version. PR: ports/109112 Submitted by: Tony Maher
Diffstat (limited to 'security/apache-xml-security-c/Makefile')
-rw-r--r--security/apache-xml-security-c/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
new file mode 100644
index 000000000000..f0d2bd6024de
--- /dev/null
+++ b/security/apache-xml-security-c/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: apache-xml-security-c
+# Date created: 06 Febuary 2007
+# Whom: Tony Maher
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-security-c
+PORTVERSION= 1.3.1
+CATEGORIES= security
+MASTER_SITES= http://xml.apache.org/security/dist/c-library/
+PKGNAMEPREFIX= apache-
+
+MAINTAINER= tonymaher@optusnet.com.au
+COMMENT= Apache XML security libraries C version
+
+LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>