aboutsummaryrefslogtreecommitdiffstats
path: root/security/arm/Makefile
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2011-11-13 20:23:01 +0800
committercs <cs@FreeBSD.org>2011-11-13 20:23:01 +0800
commit67416b6873ce146becbc64ae01388dc214735cc2 (patch)
treef25a055308b51635dd8e84535496a136694a5d01 /security/arm/Makefile
parentd97a83262f7e9b3b2bc270f65b22e892433fcf5d (diff)
downloadfreebsd-ports-gnome-67416b6873ce146becbc64ae01388dc214735cc2.tar.gz
freebsd-ports-gnome-67416b6873ce146becbc64ae01388dc214735cc2.tar.zst
freebsd-ports-gnome-67416b6873ce146becbc64ae01388dc214735cc2.zip
- Update to 1.4.4.1
- Make dependency on tor optional Approved by: glarkin@ (mentor) Feature safe: yes
Diffstat (limited to 'security/arm/Makefile')
-rw-r--r--security/arm/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/security/arm/Makefile b/security/arm/Makefile
index b0c9af6680bd..a93763124012 100644
--- a/security/arm/Makefile
+++ b/security/arm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= arm
-DISTVERSION= 1.4.4.0
+DISTVERSION= 1.4.4.1
CATEGORIES= security net python
MASTER_SITES= https://archive.torproject.org/arm/ \
http://www.c-s.li/ports/
@@ -17,21 +17,26 @@ COMMENT= A terminal status monitor for Tor
LICENSE= GPLv3
-RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof \
- tor:${PORTSDIR}/security/tor
-
MAN1= arm.1
MANCOMPRESSED= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-PYDISTUTILS_PKGVERSION=1.4.4
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
PORTDOCS= armrc.sample
+OPTIONS= TOR "Install tor locally" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TOR)
+RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof \
+ tor:${PORTSDIR}/security/tor
+.endif
+
post-patch:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's,/usr/share/doc/,${WRKSRC}/src,g' \
@@ -49,4 +54,4 @@ post-patch:
${WRKSRC}/arm ${WRKSRC}/setup.py ${WRKSRC}/src/uninstall \
${WRKSRC}/src/gui/controller.py
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>