aboutsummaryrefslogtreecommitdiffstats
path: root/security/bearssl
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-04-10 04:05:37 +0800
committerfeld <feld@FreeBSD.org>2017-04-10 04:05:37 +0800
commitf26876396f1b1751400ff1b1cc9f9e417b81b123 (patch)
tree6f11b4faad8c32ee78c7a794a77796e2bcf5847b /security/bearssl
parent04368111ac3ffb28fb6e4b8ad6e0cb9579ad8a2c (diff)
downloadfreebsd-ports-gnome-f26876396f1b1751400ff1b1cc9f9e417b81b123.tar.gz
freebsd-ports-gnome-f26876396f1b1751400ff1b1cc9f9e417b81b123.tar.zst
freebsd-ports-gnome-f26876396f1b1751400ff1b1cc9f9e417b81b123.zip
security/bearssl: Fix build with Clang
Using MAKE_ARGS allows building with clang. Submitted by: bapt
Diffstat (limited to 'security/bearssl')
-rw-r--r--security/bearssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/bearssl/Makefile b/security/bearssl/Makefile
index 7a6849278ba4..5a0f68150815 100644
--- a/security/bearssl/Makefile
+++ b/security/bearssl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bearssl
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= https://bearssl.org/
@@ -12,7 +12,7 @@ COMMENT= Implementation of TLS/SSL in C
LICENSE= MIT
-USE_GCC= yes
+MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -fPIC" LDDLL="${CC}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/brssl ${STAGEDIR}${LOCALBASE}/bin/