aboutsummaryrefslogtreecommitdiffstats
path: root/security/beecrypt
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-08 03:27:06 +0800
committertijl <tijl@FreeBSD.org>2014-07-08 03:27:06 +0800
commitd9512ba2e7e1fbc5561b5eabb0eff2a321f79b17 (patch)
tree2e28d543ac64f2fc54508cfd6859ee52030426c2 /security/beecrypt
parent9f1782acaf55a58ae0dba53f57b1999f2a6a5597 (diff)
downloadfreebsd-ports-gnome-d9512ba2e7e1fbc5561b5eabb0eff2a321f79b17.tar.gz
freebsd-ports-gnome-d9512ba2e7e1fbc5561b5eabb0eff2a321f79b17.tar.zst
freebsd-ports-gnome-d9512ba2e7e1fbc5561b5eabb0eff2a321f79b17.zip
- Convert to USES=libtool
- Add INSTALL_TARGET=install-strip - Remove use of PTHREAD_LIBS
Diffstat (limited to 'security/beecrypt')
-rw-r--r--security/beecrypt/Makefile12
-rw-r--r--security/beecrypt/pkg-plist2
2 files changed, 8 insertions, 6 deletions
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index 96b6f9b5f92e..b1bc888e3151 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -1,8 +1,9 @@
# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
+
PORTNAME= beecrypt
PORTVERSION= 4.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF
PATCHFILES= mpntrbits.patch
@@ -11,9 +12,10 @@ PATCH_SITES= http://sourceforge.net/p/beecrypt/patches/_discuss/thread/bff89ba1/
MAINTAINER= mi@aldan.algebra.com
COMMENT= BeeCrypt is an open source cryptography library
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--without-java
+CONFIGURE_ARGS= --without-java --without-python
+INSTALL_TARGET= install-strip
+USES= libtool
USE_LDCONFIG= yes
OPTIONS_DEFINE= OPENMP
@@ -22,7 +24,6 @@ OPENMP_CONFIGURE_ENABLE= openmp
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
.if ${PORT_OPTIONS:MOPENMP}
@${ECHO_MSG} "Configuring for OpenMP support"
@${ECHO_MSG} "Any ports depending on beecrypt must be configured for OpenMP too."
@@ -37,6 +38,7 @@ CPPFLAGS+= -DOPTIMIZE_${o:tu}
.endfor
regression-test test check: build
- ${MAKE} -C ${WRKSRC} check
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.mk>
diff --git a/security/beecrypt/pkg-plist b/security/beecrypt/pkg-plist
index c89258f1defd..173493e52cd7 100644
--- a/security/beecrypt/pkg-plist
+++ b/security/beecrypt/pkg-plist
@@ -54,7 +54,7 @@ include/beecrypt/sha512.h
include/beecrypt/timestamp.h
include/beecrypt/win.h
lib/libbeecrypt.a
-lib/libbeecrypt.la
lib/libbeecrypt.so
lib/libbeecrypt.so.7
+lib/libbeecrypt.so.7.0.0
@dirrm include/beecrypt