aboutsummaryrefslogtreecommitdiffstats
path: root/security/binwalk
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-02-08 09:53:00 +0800
committerjgh <jgh@FreeBSD.org>2012-02-08 09:53:00 +0800
commit50ffa31effd50aae356dc700c72abdd581118a1d (patch)
tree99e3290466e52613b649eba97f014ddc2a62b0bd /security/binwalk
parent8073d710a4362aedc851d6e78eda709640ab24f8 (diff)
downloadfreebsd-ports-gnome-50ffa31effd50aae356dc700c72abdd581118a1d.tar.gz
freebsd-ports-gnome-50ffa31effd50aae356dc700c72abdd581118a1d.tar.zst
freebsd-ports-gnome-50ffa31effd50aae356dc700c72abdd581118a1d.zip
New Port: security/binwalk
Binwalk is a tool for searching a given binary image for embedded files and executable code. Specifically, it is designed for identifying files and code embedded inside of firmware images. Binwalk uses the libmagic library, so it is compatible with magic signatures created for the Unix file utility. Binwalk also includes a custom magic signature file which contains improved signatures for files that are commonly found in firmware images such as compressed/archived files, firmware headers, Linux kernels, bootloaders, filesystems, etc. More details are available at: WWW: http://code.google.com/p/binwalk/ PR: ports/164821 Submitted by: Kurt Jaeger, fbsd-ports at opsec.eu
Diffstat (limited to 'security/binwalk')
-rw-r--r--security/binwalk/Makefile40
-rw-r--r--security/binwalk/distinfo2
-rw-r--r--security/binwalk/pkg-descr13
3 files changed, 55 insertions, 0 deletions
diff --git a/security/binwalk/Makefile b/security/binwalk/Makefile
new file mode 100644
index 000000000000..0be71ab04c5d
--- /dev/null
+++ b/security/binwalk/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: binwalk
+# Date created: 6 February 2012
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= binwalk
+PORTVERSION= 0.4.1
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= Search binary images for embedded files and executable code
+
+LICENSE= MIT
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+
+PLIST_FILES= bin/binwalk \
+ etc/binwalk/magic.binarch \
+ etc/binwalk/magic.bincast \
+ etc/binwalk/magic.binwalk \
+ etc/binwalk/magic.o
+PLIST_DIRS= etc/binwalk
+
+PORTDOCS= README
+
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/docs/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/binwalk/distinfo b/security/binwalk/distinfo
new file mode 100644
index 000000000000..a608bd9ad6bb
--- /dev/null
+++ b/security/binwalk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (binwalk-0.4.1.tar.gz) = fc82c3acbf8d809cfff7896ac69c60e1ebcf1eb30ae7819a89e4ec036cc3b8a9
+SIZE (binwalk-0.4.1.tar.gz) = 695370
diff --git a/security/binwalk/pkg-descr b/security/binwalk/pkg-descr
new file mode 100644
index 000000000000..555b5e12f0ca
--- /dev/null
+++ b/security/binwalk/pkg-descr
@@ -0,0 +1,13 @@
+Binwalk is a tool for searching a given binary image for embedded
+files and executable code. Specifically, it is designed for identifying
+files and code embedded inside of firmware images. Binwalk uses the
+libmagic library, so it is compatible with magic signatures created
+for the Unix file utility.
+
+Binwalk also includes a custom magic signature file which contains
+improved signatures for files that are commonly found in firmware
+images such as compressed/archived files, firmware headers, Linux
+kernels, bootloaders, filesystems, etc.
+More details are available at:
+
+WWW: http://code.google.com/p/binwalk/