aboutsummaryrefslogtreecommitdiffstats
path: root/security/botan110/Makefile
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-11-20 01:35:57 +0800
committertobik <tobik@FreeBSD.org>2018-11-20 01:35:57 +0800
commit73a788e4db177678c72a8c26ad323c5f2f644d72 (patch)
tree1bd87938409e38d8337470c1355f2335d0383064 /security/botan110/Makefile
parent38eaa71d0f13cce7be58af46c01706430333bdcc (diff)
downloadfreebsd-ports-gnome-73a788e4db177678c72a8c26ad323c5f2f644d72.tar.gz
freebsd-ports-gnome-73a788e4db177678c72a8c26ad323c5f2f644d72.tar.zst
freebsd-ports-gnome-73a788e4db177678c72a8c26ad323c5f2f644d72.zip
security/botan110: Attempt to unbreak consumers with OpenSSL 1.1.1
The OpenSSL 1.1.1 support added in ports r483489 was incomplete and leads to segfaults and build failures in consumers [1,2]. Amend the patch to actually allocate some memory. While here hook up the test suite. [1] http://beefy11.nyi.freebsd.org/data/head-i386-default/p483632_s339979/logs/bundy-0.20170618_10.log [2] http://beefy11.nyi.freebsd.org/data/head-i386-default/p483632_s339979/logs/monotone-1.1_13.log PR: 229030 Approved by: lapo@lapo.it (maintainer timeout, 2 weeks) Pointy hat: fluffy
Diffstat (limited to 'security/botan110/Makefile')
-rw-r--r--security/botan110/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 85d9e88abe10..26912db72a13 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -3,6 +3,7 @@
PORTNAME= botan
DISTVERSION= 1.10.17
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 110
@@ -24,11 +25,12 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
CONFIGURE_ARGS= --prefix=${PREFIX} --cc ${CHOSEN_COMPILER_TYPE} \
--with-tr1-implementation=system --with-bzip2 --with-zlib
-MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}"
+MAKE_ARGS= CXX="${CXX}" CHECK_OPT="${CXXFLAGS}" LIB_OPT="${CXXFLAGS}"
USE_LDCONFIG= yes
PLIST_FILES= bin/botan-config-1.10 lib/libbotan-1.10.a lib/libbotan-1.10.so lib/libbotan-1.10.so.1 \
lib/libbotan-1.10.so.1.17 libdata/pkgconfig/botan-1.10.pc
SHEBANG_FILES= configure.py
+TEST_TARGET= check
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
@@ -57,4 +59,7 @@ post-patch-DOCS-off:
post-install:
@(cd "${STAGEDIR}${PREFIX}"; ${FIND} -s include/botan-1.10 -not -type d) >> ${TMPPLIST}
+post-test:
+ cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH="." ./check --test
+
.include <bsd.port.post.mk>