aboutsummaryrefslogtreecommitdiffstats
path: root/security/botan
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-07-10 16:25:57 +0800
committererwin <erwin@FreeBSD.org>2003-07-10 16:25:57 +0800
commit0bbb0864314e255bdd03a645e904a0fa798c9b14 (patch)
treebfdc75609c58c251945e3b42754d7159c12351de /security/botan
parentbeb3cd302da39ee6982876cfc93a705e9c4d3245 (diff)
downloadfreebsd-ports-gnome-0bbb0864314e255bdd03a645e904a0fa798c9b14.tar.gz
freebsd-ports-gnome-0bbb0864314e255bdd03a645e904a0fa798c9b14.tar.zst
freebsd-ports-gnome-0bbb0864314e255bdd03a645e904a0fa798c9b14.zip
Add missing dependency
PR: 54282 Submitted by: bento, Kirill Ponomarew <ponomarew@oberon.net>
Diffstat (limited to 'security/botan')
-rw-r--r--security/botan/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index dd01e226c128..2d866e98a36b 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -30,6 +30,13 @@ INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g ; \
s,%%CFLAGS%%,${CFLAGS},g" ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -38,4 +45,4 @@ post-patch:
post-install:
@${RM} -f ${PREFIX}/include/botan/botan
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>