aboutsummaryrefslogtreecommitdiffstats
path: root/security/bsmtrace
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-09 04:54:44 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-09 04:54:44 +0800
commit755028c9998bdb0a88f7f09f9a9e442883a2865a (patch)
tree9dd22eab37199b1167f12efb232b1cb80bf0fa0f /security/bsmtrace
parent4da93896a8844403da2f440f0ac941628cb33a67 (diff)
downloadfreebsd-ports-gnome-755028c9998bdb0a88f7f09f9a9e442883a2865a.tar.gz
freebsd-ports-gnome-755028c9998bdb0a88f7f09f9a9e442883a2865a.tar.zst
freebsd-ports-gnome-755028c9998bdb0a88f7f09f9a9e442883a2865a.zip
- Support staging
- Respect CC - Respect CFLAGS - Fix build with PCRE option - Convert to OPTIONSng
Diffstat (limited to 'security/bsmtrace')
-rw-r--r--security/bsmtrace/Makefile30
-rw-r--r--security/bsmtrace/files/patch-Makefile16
-rw-r--r--security/bsmtrace/pkg-plist2
3 files changed, 33 insertions, 15 deletions
diff --git a/security/bsmtrace/Makefile b/security/bsmtrace/Makefile
index 77bee802ca72..3b413a483f57 100644
--- a/security/bsmtrace/Makefile
+++ b/security/bsmtrace/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bsmtrace
PORTVERSION= 1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= csjp
@@ -12,30 +12,30 @@ MAINTAINER= alm@FreeBSD.org
COMMENT= BSM based intrusion detection system
SUB_FILES= pkg-message
-MAN1= bsmtrace.1
-MAN5= bsmtrace.conf.5
MAKE_JOBS_UNSAFE= yes
-.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
-MAKE_ENV+= PCRE=1
+OPTIONS_DEFINE= PCRE EXAMPLES
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPCRE}
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+MAKE_ENV+= PCRE=1 LIBS="-lpcre -L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include
.endif
-NO_STAGE= yes
pre-build:
${REINPLACE_CMD} -e \
's,/etc/bsmtrace.conf,${PREFIX}/etc/bsmtrace.conf,' \
${WRKSRC}/config.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bsmtrace ${PREFIX}/sbin
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/bsmtrace.conf ${EXAMPLESDIR}
- ${INSTALL_MAN} ${WRKSRC}/bsmtrace.1 ${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/bsmtrace.conf.5 ${MAN5PREFIX}/man/man5
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.conf.5 \
+ ${STAGEDIR}${MAN5PREFIX}/man/man5
.include <bsd.port.mk>
diff --git a/security/bsmtrace/files/patch-Makefile b/security/bsmtrace/files/patch-Makefile
new file mode 100644
index 000000000000..b67a2b410735
--- /dev/null
+++ b/security/bsmtrace/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- ./Makefile.orig 2011-06-03 17:48:11.000000000 +0200
++++ ./Makefile 2014-02-08 21:49:46.465613358 +0100
+@@ -1,11 +1,10 @@
+ # $Id: Makefile,v 1.8 2007/07/13 00:03:50 csjp Exp $
+
+-CC = gcc
+-CFLAGS = -Wall -g
++CC ?= gcc
+ TARGETS = bsmtrace
+ OBJ = bsm.o bsmtrace.o conf.o y.tab.o lex.yy.o log.o pipe.o trigger.o fcache.o
+ PREFIX = /usr/local
+-LIBS = -lbsm
++LIBS += -lbsm
+
+ #.ifdef PCRE
+ #CFLAGS += -I /usr/local/include
diff --git a/security/bsmtrace/pkg-plist b/security/bsmtrace/pkg-plist
index 4d955c750db2..272739a21fda 100644
--- a/security/bsmtrace/pkg-plist
+++ b/security/bsmtrace/pkg-plist
@@ -1,3 +1,5 @@
sbin/bsmtrace
+man/man1/bsmtrace.1.gz
+man/man5/bsmtrace.conf.5.gz
%%EXAMPLESDIR%%/bsmtrace.conf
@dirrm %%EXAMPLESDIR%%