aboutsummaryrefslogtreecommitdiffstats
path: root/security/bugs/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-13 09:40:27 +0800
committeredwin <edwin@FreeBSD.org>2003-10-13 09:40:27 +0800
commiteec57a6e2ce31c46ab3e11f98d534daba45de3bc (patch)
tree1fe0d91ed0fb99d0225e37f57c6d98916fe0e6e0 /security/bugs/Makefile
parentf644b6587a19aa08a9d4b4615876f5aed110c192 (diff)
downloadfreebsd-ports-gnome-eec57a6e2ce31c46ab3e11f98d534daba45de3bc.tar.gz
freebsd-ports-gnome-eec57a6e2ce31c46ab3e11f98d534daba45de3bc.tar.zst
freebsd-ports-gnome-eec57a6e2ce31c46ab3e11f98d534daba45de3bc.zip
Fix strange permissions on directories which fail to make the port
patch properly without root permissions.
Diffstat (limited to 'security/bugs/Makefile')
-rw-r--r--security/bugs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/security/bugs/Makefile b/security/bugs/Makefile
index 0ebb6f005ecc..f5601272372c 100644
--- a/security/bugs/Makefile
+++ b/security/bugs/Makefile
@@ -21,6 +21,9 @@ USE_REINPLACE= yes
# No Manual page
+post-extract:
+ ${FIND} ${WRKSRC} -type d -exec ${CHMOD} +x {} \;
+
post-configure:
(cd ${WRKSRC}; ${MAKE} bsd);
${REINPLACE_CMD} -e 's:^INSTALL_PATH = "/usr/local/bugs-.*":INSTALL_PATH = "${PREFIX}/${DISTNAME}":' ${WRKSRC}/Makefile;