aboutsummaryrefslogtreecommitdiffstats
path: root/security/checkpassword
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-23 22:46:08 +0800
committergarga <garga@FreeBSD.org>2006-07-23 22:46:08 +0800
commite06f87fc8f68232ce394fa219b29f7aae643a2a2 (patch)
tree15c819ed45a575be8cb391da3906e56b15be95ba /security/checkpassword
parent72dce7588f8d66334207b908997914afde9b7124 (diff)
downloadfreebsd-ports-gnome-e06f87fc8f68232ce394fa219b29f7aae643a2a2.tar.gz
freebsd-ports-gnome-e06f87fc8f68232ce394fa219b29f7aae643a2a2.tar.zst
freebsd-ports-gnome-e06f87fc8f68232ce394fa219b29f7aae643a2a2.zip
- Respect CC and CFLAGS
- Unquote RESTRICTED
Diffstat (limited to 'security/checkpassword')
-rw-r--r--security/checkpassword/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/checkpassword/Makefile b/security/checkpassword/Makefile
index 6b662141e4ee..5e29b811f06a 100644
--- a/security/checkpassword/Makefile
+++ b/security/checkpassword/Makefile
@@ -15,20 +15,20 @@ COMMENT= A simple password-checking interface
ALL_TARGET= it
INSTALL_TARGET= setup
-RESTRICTED= "Unsure of djb's license"
+RESTRICTED= Unsure of djb's license
PLIST_FILES= bin/checkpassword
PORTDOCS= CHANGES FILES README SYSDEPS TARGETS TODO VERSION
do-configure:
- ${ECHO_CMD} 'cc -s -lcrypt' > ${WRKSRC}/conf-ld
- ${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
+ @${ECHO_CMD} '${CC} ${CFLAGS} -s -lcrypt' > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif