aboutsummaryrefslogtreecommitdiffstats
path: root/security/cksfv/files
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-28 20:44:15 +0800
committerjeh <jeh@FreeBSD.org>2000-10-28 20:44:15 +0800
commit92b0ae3e56e8ed034ebfeb7a608de778c8b3b441 (patch)
tree238c9d15a68e72f430274cd2a52e50f14e4fe158 /security/cksfv/files
parent3e5deb59d4914ae345c91a8491d69d6a070ea4b7 (diff)
downloadfreebsd-ports-gnome-92b0ae3e56e8ed034ebfeb7a608de778c8b3b441.tar.gz
freebsd-ports-gnome-92b0ae3e56e8ed034ebfeb7a608de778c8b3b441.tar.zst
freebsd-ports-gnome-92b0ae3e56e8ed034ebfeb7a608de778c8b3b441.zip
New Port: security/cksfv
Create or manipulate Simple File Verification (SFV) checksum files PR: 22075 Submitted by: Johann Visagie <johann@egenetics.com>
Diffstat (limited to 'security/cksfv/files')
-rw-r--r--security/cksfv/files/patch-src-Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/security/cksfv/files/patch-src-Makefile b/security/cksfv/files/patch-src-Makefile
new file mode 100644
index 000000000000..5b16eb6b2bac
--- /dev/null
+++ b/security/cksfv/files/patch-src-Makefile
@@ -0,0 +1,20 @@
+--- src/Makefile.orig Mon May 22 23:57:05 2000
++++ src/Makefile Wed Oct 18 10:14:25 2000
+@@ -17,14 +17,15 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ PROG= cksfv
++CC?= gcc
+ CFLAGS+= -Wall -Werror -O2
+ SRCS= cksfv.c print.c crc32.c readsfv.c newsfv.c
+
+ cksfv: $(SRCS)
+- gcc $(CFLAGS) -o $(PROG) $(SRCS)
++ $(CC) $(CFLAGS) -o $(PROG) $(SRCS)
+
+ install: cksfv
+- cp $(PROG) /usr/local/bin
++ $(BSD_INSTALL_PROGRAM) $(PROG) $(PREFIX)/bin
+
+ clean:
+ rm -f *.o *~ *.core $(PROG)