aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav-devel/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-05 06:49:52 +0800
committerpav <pav@FreeBSD.org>2004-11-05 06:49:52 +0800
commit3d81ba63e3f42319f0af451e373c0c6b40e10986 (patch)
tree6475d8e49f8f13477e61fa130f985c8f85e73c4c /security/clamav-devel/files
parent869f0e4f7211d819a9409d11cbc9da93527c42bf (diff)
downloadfreebsd-ports-gnome-3d81ba63e3f42319f0af451e373c0c6b40e10986.tar.gz
freebsd-ports-gnome-3d81ba63e3f42319f0af451e373c0c6b40e10986.tar.zst
freebsd-ports-gnome-3d81ba63e3f42319f0af451e373c0c6b40e10986.zip
- Update to 20041101
- Configuration file was renamed to clamd.conf! PR: ports/73491 Submitted by: Rob Evers <rob@debank.tv> (maintainer)
Diffstat (limited to 'security/clamav-devel/files')
-rw-r--r--security/clamav-devel/files/clamav-clamd.sh20
-rw-r--r--security/clamav-devel/files/clamav-freshclam.sh16
-rw-r--r--security/clamav-devel/files/clamav-milter.sh13
-rw-r--r--security/clamav-devel/files/patch-Makefile.am10
-rw-r--r--security/clamav-devel/files/patch-configure.in25
-rw-r--r--security/clamav-devel/files/patch-etc::Makefile.am12
6 files changed, 42 insertions, 54 deletions
diff --git a/security/clamav-devel/files/clamav-clamd.sh b/security/clamav-devel/files/clamav-clamd.sh
index 243a3fba871b..453212555e2f 100644
--- a/security/clamav-devel/files/clamav-clamd.sh
+++ b/security/clamav-devel/files/clamav-clamd.sh
@@ -24,20 +24,12 @@ rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/clamd
pidfile=/var/run/clamav/clamd.pid
required_dirs=%%DATADIR%%
-required_files=%%PREFIX%%/etc/clamav.conf
+required_files=%%PREFIX%%/etc/clamd.conf
-stop_postcmd=stop_postcmd
+# read settings, set default values
+load_rc_config "$name"
+: ${clamav_clamd_enable="NO"}
+: ${clamav_clamd_flags=""}
+: ${clamav_clamd_socket="%%CLAMAV_CLAMD_SOCKET%%"}
-stop_postcmd()
-{
- rm -f $pidfile
-}
-
-# set defaults
-
-clamav_clamd_enable=${clamav_clamd_enable:-"NO"}
-clamav_clamd_flags=${clamav_clamd_flags:-""}
-clamav_clamd_socket=${clamav_clamd_socket:-"%%CLAMAV_CLAMD_SOCKET%%"}
-
-load_rc_config $name
run_rc_command "$1"
diff --git a/security/clamav-devel/files/clamav-freshclam.sh b/security/clamav-devel/files/clamav-freshclam.sh
index 5ce32d2d1ff8..a4f710b2aa53 100644
--- a/security/clamav-devel/files/clamav-freshclam.sh
+++ b/security/clamav-devel/files/clamav-freshclam.sh
@@ -9,7 +9,7 @@
# KEYWORD: FreeBSD shutdown
#
-# Add the following lines to /etc/rc.conf to enable freshclam daemon:
+# Add the following lines to /etc/rc.conf to enable the freshclam daemon:
#
#clamav_freshclam_enable="YES"
#
@@ -22,16 +22,14 @@ name=clamav_freshclam
rcvar=`set_rcvar`
command=%%PREFIX%%/bin/freshclam
+pidfile=/var/run/clamav/freshclam.pid
+command_args="--daemon"
required_dirs=%%DATADIR%%
required_files=%%PREFIX%%/etc/freshclam.conf
-# set defaults
+# read settings, set default values
+load_rc_config "$name"
+: ${clamav_freshclam_enable="NO"}
+: ${clamav_freshclam_flags=""}
-clamav_freshclam_enable=${clamav_freshclam_enable:-"NO"}
-clamav_freshclam_flags=${clamav_freshclam_flags:-"--pid=/var/run/clamav/freshclam.pid --daemon-notify=%%PREFIX%%/etc/clamav.conf"}
-
-load_rc_config $name
-
-# add --daemon to any given arguments
-clamav_freshclam_flags="${clamav_freshclam_flags} --daemon"
run_rc_command "$1"
diff --git a/security/clamav-devel/files/clamav-milter.sh b/security/clamav-devel/files/clamav-milter.sh
index 98f33717d2cb..e3679e66ec26 100644
--- a/security/clamav-devel/files/clamav-milter.sh
+++ b/security/clamav-devel/files/clamav-milter.sh
@@ -23,7 +23,7 @@ rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/clamav-milter
required_dirs=%%DATADIR%%
-required_files=%%PREFIX%%/etc/clamav.conf
+required_files=%%PREFIX%%/etc/clamd.conf
start_precmd=start_precmd
@@ -33,15 +33,14 @@ start_precmd()
warn "Stale socket $clamav_milter_socket removed."
rm "$clamav_milter_socket"
fi
+ rc_flags="${flags:-$clamav_milter_flags} $clamav_milter_socket"
}
-# set defaults
-
-clamav_milter_enable=${clamav_milter_enable:-"NO"}
-clamav_milter_socket=${clamav_milter_socket:-"%%CLAMAV_MILTER_SOCKET%%"}
-clamav_milter_flags=${clamav_milter_flags:-"--postmaster-only --local --outgoing --max-children=50"}
-
+# read settings, set default values
load_rc_config $name
+: ${clamav_milter_enable="NO"}
+: ${clamav_milter_socket="%%CLAMAV_MILTER_SOCKET%%"}
+: ${clamav_milter_flags="--postmaster-only --local --outgoing --max-children=50"}
# add socket to any given argument
clamav_milter_flags="${clamav_milter_flags} ${clamav_milter_socket}"
diff --git a/security/clamav-devel/files/patch-Makefile.am b/security/clamav-devel/files/patch-Makefile.am
new file mode 100644
index 000000000000..186cd51dac1a
--- /dev/null
+++ b/security/clamav-devel/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig Sat Oct 16 17:43:47 2004
++++ Makefile.am Sat Oct 16 17:44:12 2004
+@@ -20,6 +20,6 @@
+
+ bin_SCRIPTS=clamav-config
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libclamav.pc
+
diff --git a/security/clamav-devel/files/patch-configure.in b/security/clamav-devel/files/patch-configure.in
index 2a49133a10a1..ada5449f5d18 100644
--- a/security/clamav-devel/files/patch-configure.in
+++ b/security/clamav-devel/files/patch-configure.in
@@ -9,27 +9,4 @@
- CLAMAV_MILTER_LIBS="$CLAMAV_MILTER_LIBS -pthread -lc_r"
TH_SAFE="-thread-safe"
AC_DEFINE(CL_THREAD_SAFE,1,[thread safe])
- AC_DEFINE(_REENTRANT,1,[thread safe])
-@@ -510,6 +507,8 @@
-
- dnl Check for gethostbyname_r and number of its arguments
- dnl Code from libwww/configure.in
-+AC_CHECK_FUNC(gethostbyname_r)
-+if test $ac_cv_func_gethostbyname_r = 'yes'; then
- AC_MSG_CHECKING(for gethostbyname_r)
- if test -z "$ac_cv_gethostbyname_args"; then
- AC_TRY_COMPILE(
-@@ -565,6 +564,13 @@
- AC_DEFINE(HAVE_GETHOSTBYNAME_R_6,1,[gethostbyname_r takes 6 arguments])
- fi
- AC_MSG_RESULT([yes, and it takes $ac_cv_gethostbyname_args arguments])
-+fi
-+else
-+dnl Check for gethostbyname()
-+AC_CHECK_FUNC(gethostbyname)
-+if test $ac_cv_func_gethostbyname = 'no'; then
-+ AC_MSG_ERROR(***** fail on check gethostbyname())
-+fi
- fi
-
- dnl Check for clamav in /etc/passwd
+ AC_DEFINE(_REENTRANT,1,[thread safe]) \ No newline at end of file
diff --git a/security/clamav-devel/files/patch-etc::Makefile.am b/security/clamav-devel/files/patch-etc::Makefile.am
new file mode 100644
index 000000000000..7790996e3ad5
--- /dev/null
+++ b/security/clamav-devel/files/patch-etc::Makefile.am
@@ -0,0 +1,12 @@
+--- etc/Makefile.am.orig Sat Oct 2 23:09:13 2004
++++ etc/Makefile.am Sun Oct 17 13:04:24 2004
+@@ -20,7 +20,5 @@
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(CFGINST)
+- @test -f $(DESTDIR)$(CFGINST)/clamd.conf || \
+- $(INSTALL_DATA) $(srcdir)/clamd.conf $(DESTDIR)$(CFGINST)
+- @test -f $(DESTDIR)$(CFGINST)/freshclam.conf || \
+- $(INSTALL_DATA) $(srcdir)/freshclam.conf $(DESTDIR)$(CFGINST)
++ $(INSTALL_DATA) $(srcdir)/clamd.conf $(DESTDIR)$(CFGINST)/clamd.conf.default
++ $(INSTALL_DATA) $(srcdir)/freshclam.conf $(DESTDIR)$(CFGINST)/freshclam.conf.default