aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav-devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-05-21 01:45:57 +0800
committergarga <garga@FreeBSD.org>2008-05-21 01:45:57 +0800
commit1cc4d80f890458dc2487e70980c32fac5e2925ad (patch)
tree16a1bb47cf37562ae61cc80ce356284b760bc428 /security/clamav-devel
parent82534df1f18f69e5750fbb7eefa134957d93d394 (diff)
downloadfreebsd-ports-gnome-1cc4d80f890458dc2487e70980c32fac5e2925ad.tar.gz
freebsd-ports-gnome-1cc4d80f890458dc2487e70980c32fac5e2925ad.tar.zst
freebsd-ports-gnome-1cc4d80f890458dc2487e70980c32fac5e2925ad.zip
- Update to 20080520
- Change OPTION UNRAR on by default to align with clamav port - USE_GMAKE to build fine new version
Diffstat (limited to 'security/clamav-devel')
-rw-r--r--security/clamav-devel/Makefile11
-rw-r--r--security/clamav-devel/distinfo6
-rw-r--r--security/clamav-devel/files/clamav-clamd.in9
-rw-r--r--security/clamav-devel/pkg-plist15
4 files changed, 23 insertions, 18 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index f4921b0c2a44..3cb55ff82068 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 20080221
+PORTVERSION= 20080520
CATEGORIES= security
MASTER_SITES= http://www.clamav.net/snapshot/ \
${MASTER_SITE_LOCAL}
@@ -23,7 +23,7 @@ OPTIONS= ARC "Enable arch archives support" On \
ARJ "Enable arj archives support" On \
LHA "Enable lha archives support" On \
UNZOO "Enable zoo archives support" On \
- UNRAR "Enable rar archives support" Off \
+ UNRAR "Enable rar archives support" On \
MILTER "Compile the milter interface" Off \
LDAP "libmilter was built with LDAP" Off \
ICONV "Enable ICONV support" Off \
@@ -33,6 +33,7 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
USE_RC_SUBR= clamav-clamd clamav-freshclam
+USE_GMAKE= yes
PORTDOCS= *
@@ -53,7 +54,6 @@ CONFIGURE_ARGS= --with-dbdir=${DBDIR} \
--disable-dependency-tracking \
--enable-experimental
CPPFLAGS+= -I${LOCALBASE}/include \
- -I../libclamav \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
@@ -112,11 +112,6 @@ CONFIGURE_ARGS+= --enable-gethostbyname_r
# force to use -lthr until it's not fixed.
.if ${OSVERSION} >= 601000
PTHREAD_LIBS= -lthr
-# Maybe the port is broken for
-# FreeBSD 5.2.1 since -lc_r
-# and -pthread have both issues there.
-.elif ${OSVERSION} == 502010
-PTHREAD_LIBS= -pthread
.else
PTHREAD_LIBS= -lpthread
.endif
diff --git a/security/clamav-devel/distinfo b/security/clamav-devel/distinfo
index e7174156df72..e0be9c1a34ab 100644
--- a/security/clamav-devel/distinfo
+++ b/security/clamav-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (clamav-devel-20080221.tar.gz) = 19149df2843aaebd95ebc65e87a923ea
-SHA256 (clamav-devel-20080221.tar.gz) = 4f9f0725b14894b54f1ea28d354adfcc925bd735d2bcf4b90e06cd31f23723a3
-SIZE (clamav-devel-20080221.tar.gz) = 2581232
+MD5 (clamav-devel-20080520.tar.gz) = 6146ebaa53ad525e4b7b3e55844d255e
+SHA256 (clamav-devel-20080520.tar.gz) = 69e34ca54097ea7d8343f090ee0c9de8cbf30cf87fe7cccb3d34a9cfcba7d633
+SIZE (clamav-devel-20080520.tar.gz) = 2691654
diff --git a/security/clamav-devel/files/clamav-clamd.in b/security/clamav-devel/files/clamav-clamd.in
index 6164dfaf5176..81425ffe9304 100644
--- a/security/clamav-devel/files/clamav-clamd.in
+++ b/security/clamav-devel/files/clamav-clamd.in
@@ -32,4 +32,13 @@ load_rc_config "$name"
: ${clamav_clamd_flags=""}
: ${clamav_clamd_socket="%%CLAMAV_CLAMD_SOCKET%%"}
+start_precmd=clamav_clamd_precmd
+
+clamav_clamd_precmd() {
+ if [ ! -f %%DBDIR%%/main.cvd ];then
+ echo "Missing %%DBDIR%%/clamav/*.cvd files. You must run freshclam first"
+ exit 1
+ fi
+}
+
run_rc_command "$1"
diff --git a/security/clamav-devel/pkg-plist b/security/clamav-devel/pkg-plist
index 79ac9ef65b92..91cf92feafa9 100644
--- a/security/clamav-devel/pkg-plist
+++ b/security/clamav-devel/pkg-plist
@@ -1,4 +1,5 @@
@comment $FreeBSD$
+bin/check_clamav
bin/clamav-config
bin/clamconf
bin/clamscan
@@ -12,15 +13,15 @@ include/clamav-config.h
lib/libclamav.a
lib/libclamav.la
lib/libclamav.so
-lib/libclamav.so.3
-%%UNRAR%%lib/libclamunrar.so.3
-%%UNRAR%%lib/libclamunrar.so
-%%UNRAR%%lib/libclamunrar.la
+lib/libclamav.so.4
%%UNRAR%%lib/libclamunrar.a
-%%UNRAR%%lib/libclamunrar_iface.so.3
-%%UNRAR%%lib/libclamunrar_iface.so
-%%UNRAR%%lib/libclamunrar_iface.la
+%%UNRAR%%lib/libclamunrar.la
+%%UNRAR%%lib/libclamunrar.so
+%%UNRAR%%lib/libclamunrar.so.4
%%UNRAR%%lib/libclamunrar_iface.a
+%%UNRAR%%lib/libclamunrar_iface.la
+%%UNRAR%%lib/libclamunrar_iface.so
+%%UNRAR%%lib/libclamunrar_iface.so.4
libdata/pkgconfig/libclamav.pc
@unexec if cmp -s %D/etc/clamd.conf %D/etc/clamd.conf.default; then rm -f %D/etc/clamd.conf; fi
etc/clamd.conf.default