aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorsilby <silby@FreeBSD.org>2003-11-28 13:58:48 +0800
committersilby <silby@FreeBSD.org>2003-11-28 13:58:48 +0800
commit2f9557a6d4f1c2274d57bf5d421d2aed6d149d9f (patch)
tree43e6f73f3363b3d870be0fcb683044c2611b7905 /security/clamav
parentff6203e36265397f1ce5c8d005e466ec36bd302a (diff)
downloadfreebsd-ports-gnome-2f9557a6d4f1c2274d57bf5d421d2aed6d149d9f.tar.gz
freebsd-ports-gnome-2f9557a6d4f1c2274d57bf5d421d2aed6d149d9f.tar.zst
freebsd-ports-gnome-2f9557a6d4f1c2274d57bf5d421d2aed6d149d9f.zip
Clamav 0.65 uses libgmp for digital signature calculations;
as libgmp no longer exists in 5.x, add the needed dependency to this Makefile. (Note that stale gmp.h and libgmp files sitting around may still cause problems, anyone with an "old" 5.x system that sees oddities in the build should make sure that those old files are purged from /usr/lib and /usr/include.)
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 408e15866d6c..31bd6a5f9291 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -72,6 +72,12 @@ CFLAGS+= -O
LDFLAGS+= -lcipher
.endif
+.if ${OSVERSION} > 501113
+# Approximate time libgmp was removed from the base system
+LDFLAGS+= -L${LOCALBASE}/lib
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+.endif
+
.if defined(WITH_MILTER)
USE_GETOPT_LONG= yes
CONFIGURE_ARGS+= --enable-milter