aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authoryar <yar@FreeBSD.org>2005-01-13 02:13:08 +0800
committeryar <yar@FreeBSD.org>2005-01-13 02:13:08 +0800
commit7ce68dcb0163586b191190cfb672c03ca76797cf (patch)
tree02f5cbefb16524899112f7693c7eea8c5e373ea3 /security/clamav
parentcee69bc70debc6054347fd12f683df9400d9815f (diff)
downloadfreebsd-ports-gnome-7ce68dcb0163586b191190cfb672c03ca76797cf.tar.gz
freebsd-ports-gnome-7ce68dcb0163586b191190cfb672c03ca76797cf.tar.zst
freebsd-ports-gnome-7ce68dcb0163586b191190cfb672c03ca76797cf.zip
Do the things I forgot about in my previous commit:
- Change the last instance of literal `/var/run/clamav' to %%RUNDIR%%. - Bump PORTREVISION since the changes should improve the functionality of the installed package. PR: ports/75607 Approved by: maintainer
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile2
-rw-r--r--security/clamav/pkg-install12
2 files changed, 7 insertions, 7 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index e905e8de09a3..1e9a816bed80 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamav
PORTVERSION= ${DISTVERSION:C/([a-z])[a-z]*/.\1/g:S/-/./g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
diff --git a/security/clamav/pkg-install b/security/clamav/pkg-install
index 697796086e36..4fb8222a95e5 100644
--- a/security/clamav/pkg-install
+++ b/security/clamav/pkg-install
@@ -9,9 +9,9 @@ CLAMAVGROUP=%%CLAMAVGROUP%%
UID=106
GID=$UID
-CLAMRUN=$DESTDIR/var/run/clamav
CLAMLOG=$DESTDIR/var/log/clamav
DBDIR=$DESTDIR%%DBDIR%%
+RUNDIR=$DESTDIR%%RUNDIR%%
if [ "$2" = "PRE-INSTALL" ]; then
@@ -39,11 +39,6 @@ if [ "$2" = "PRE-INSTALL" ]; then
elif [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "$CLAMRUN" ]; then
- mkdir -p "$CLAMRUN" || exit 1
- chown "$CLAMAVUSER:$CLAMAVGROUP" "$CLAMRUN" || exit 1
- fi
-
if [ ! -d "$CLAMLOG" ]; then
mkdir -p "$CLAMLOG" || exit 1
chown "$CLAMAVUSER:$CLAMAVGROUP" "$CLAMLOG" || exit 1
@@ -54,6 +49,11 @@ elif [ "$2" = "POST-INSTALL" ]; then
chown "$CLAMAVUSER:$CLAMAVGROUP" "$DBDIR" || exit 1
fi
+ if [ ! -d "$RUNDIR" ]; then
+ mkdir -p "$RUNDIR" || exit 1
+ chown "$CLAMAVUSER:$CLAMAVGROUP" "$RUNDIR" || exit 1
+ fi
+
if [ -f "$DESTDIR$PREFIX/etc/clamav.conf" ]; then
echo
echo "**************** WARNING ****************"