aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2014-01-17 06:56:12 +0800
committergarga <garga@FreeBSD.org>2014-01-17 06:56:12 +0800
commit4082139e68f7586ab5bb1c9a4522762a4c8d09d0 (patch)
tree4768ae2ab14c496fcf3d69a416f8c0a81dc9a07a /security/clamav
parent662383b1225ee25a4285ab97b669329e15f8938f (diff)
downloadfreebsd-ports-gnome-4082139e68f7586ab5bb1c9a4522762a4c8d09d0.tar.gz
freebsd-ports-gnome-4082139e68f7586ab5bb1c9a4522762a4c8d09d0.tar.zst
freebsd-ports-gnome-4082139e68f7586ab5bb1c9a4522762a4c8d09d0.zip
Update to 0.98.1
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile10
-rw-r--r--security/clamav/distinfo4
-rw-r--r--security/clamav/files/patch-libclamav__bignum_fast.h32
3 files changed, 8 insertions, 38 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index db2aa6d1b10b..19bddbc46c59 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= clamav
-PORTVERSION= 0.98
-PORTREVISION= 3
+PORTVERSION= 0.98.1
CATEGORIES= security
MASTER_SITES= SF
@@ -13,7 +12,7 @@ COMMENT= Command line virus scanner written entirely in C
LICENSE= GPLv2
OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR \
- EXPERIMENTAL DOCS IPV6
+ EXPERIMENTAL DOCS IPV6 DMG_XAR
ARC_DESC= Enable arch archives support
ARJ_DESC= Enable arj archives support
@@ -25,8 +24,9 @@ TESTS_DESC= Run compile-time tests (req. python)
MILTER_DESC= Compile the milter interface
STDERR_DESC= Print logs to stderr instead of stdout
EXPERIMENTAL_DESC= Build experimental code
+DMG_XAR_DESC= Enable DMG and XAR archives support
-OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM DOCS IPV6
+OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM DOCS IPV6 DMG_XAR
ARC_RUN_DEPENDS= arc:${PORTSDIR}/archivers/arc
ARJ_RUN_DEPENDS= arj:${PORTSDIR}/archivers/arj
@@ -41,6 +41,8 @@ ICONV_CONFIGURE_OFF= --without-iconv
ICONV_USES= iconv
EXPERIMENTAL_CONFIGURE_ENABLE= experimental
IPV6_CONFIGURE_ENABLE= ipv6
+DMG_XAR_CONFIGURE_ENABLE= xml
+DMG_XAR_USE= GNOME=libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/clamav/distinfo b/security/clamav/distinfo
index d50756ae989d..75a77da505a8 100644
--- a/security/clamav/distinfo
+++ b/security/clamav/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clamav-0.98.tar.gz) = 113450537f46ed47f010a179be333a0dcd79eac13f264dce26db7aac8d52b3b6
-SIZE (clamav-0.98.tar.gz) = 37075245
+SHA256 (clamav-0.98.1.tar.gz) = 35f5e84d734cdd4532c1cc6c92560c5b31d1c24f2e1e203bef0ca1351eb223dc
+SIZE (clamav-0.98.1.tar.gz) = 15431484
diff --git a/security/clamav/files/patch-libclamav__bignum_fast.h b/security/clamav/files/patch-libclamav__bignum_fast.h
deleted file mode 100644
index 98c1ff4a1db7..000000000000
--- a/security/clamav/files/patch-libclamav__bignum_fast.h
+++ /dev/null
@@ -1,32 +0,0 @@
---- libclamav/bignum_fast.h
-+++ libclamav/bignum_fast.h
-@@ -7,6 +7,14 @@
- *
- * Tom St Denis, tomstdenis@gmail.com
- */
-+
-+/* Oct 1, 2013
-+ * Adding clamav-config.h include here for size-checking on fall-through case
-+ */
-+#if HAVE_CONFIG_H
-+#include "clamav-config.h"
-+#endif
-+
- #ifndef TFM_H_
- #define TFM_H_
-
-@@ -249,7 +257,13 @@
- typedef signed long long long64;
- #endif
- #endif
-- typedef unsigned long fp_digit;
-+ /* The code requires that fp_word be twice the size of fp_digit.
-+ * Add size-checking for special case (both long and long long are 64) */
-+ #if (SIZEOF_LONG == 8) && (SIZEOF_LONG_LONG == 8)
-+ typedef unsigned int fp_digit;
-+ #else
-+ typedef unsigned long fp_digit;
-+ #endif
- typedef ulong64 fp_word;
- #endif
-