aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-06-23 03:25:41 +0800
committerscheidell <scheidell@FreeBSD.org>2012-06-23 03:25:41 +0800
commit1df76e959c9ffceb984aad614fcc4fa1cee335e2 (patch)
treea82e8a6f9b575cd0b6f0a7a9dcba0d800ed4eacb /security/clamav
parentceb05fafb076a55fe7ae1d192af813ada78abd1a (diff)
downloadfreebsd-ports-gnome-1df76e959c9ffceb984aad614fcc4fa1cee335e2.tar.gz
freebsd-ports-gnome-1df76e959c9ffceb984aad614fcc4fa1cee335e2.tar.zst
freebsd-ports-gnome-1df76e959c9ffceb984aad614fcc4fa1cee335e2.zip
- Fix CL_FORMAT bug introducted by clamav in version 0.97.5 (their bug #5252)
Submitted by: scheidell@ (me) Approved by: Renato Botelho <garga@FreeBSD.org> (maintainer, via private email) Obtained from: https://bugzilla.clamav.net/show_bug.cgi?id=5252
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile1
-rw-r--r--security/clamav/files/patch-libclamav__scanners.c_bug_525223
2 files changed, 24 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 6bf7ae40ef71..7759bdc356f6 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.97.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/clamav/files/patch-libclamav__scanners.c_bug_5252 b/security/clamav/files/patch-libclamav__scanners.c_bug_5252
new file mode 100644
index 000000000000..6a21dedb24ef
--- /dev/null
+++ b/security/clamav/files/patch-libclamav__scanners.c_bug_5252
@@ -0,0 +1,23 @@
+--- libclamav/scanners.c.orig
++++ libclamav/scanners.c
+@@ -2369,7 +2369,19 @@ static int magic_scandesc(cli_ctx *ctx, cli_file_t type)
+ ret = res;
+ cli_bitset_free(ctx->hook_lsig_matches);
+ ctx->hook_lsig_matches = old_hook_lsig_matches;
+- ret_from_magicscan(ret);
++ /* Same switch as end of magic_scandesc function */
++ switch(ret) {
++ case CL_EFORMAT:
++ case CL_EMAXREC:
++ case CL_EMAXSIZE:
++ case CL_EMAXFILES:
++ cli_dbgmsg("Descriptor: %s\n", cl_strerror(ret));
++ case CL_CLEAN: /* here, only from cli_checkfp() */
++ cache_add(hash, hashed_size, ctx);
++ ret_from_magicscan(CL_CLEAN);
++ default:
++ ret_from_magicscan(ret);
++ }
+ }
+ }
+