aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamcour/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-03-27 19:53:07 +0800
committergarga <garga@FreeBSD.org>2009-03-27 19:53:07 +0800
commitb34da632f219f529ad066c87e48fa3c252657dc6 (patch)
tree322caa19218f2feb61aea674aee1edf7b16c4495 /security/clamcour/Makefile
parent91184f3932a6455516109f898bae81c1e084dddf (diff)
downloadfreebsd-ports-gnome-b34da632f219f529ad066c87e48fa3c252657dc6.tar.gz
freebsd-ports-gnome-b34da632f219f529ad066c87e48fa3c252657dc6.tar.zst
freebsd-ports-gnome-b34da632f219f529ad066c87e48fa3c252657dc6.zip
- Bump necessary PORTREVISIONS and fix some ports to new clamav API
Diffstat (limited to 'security/clamcour/Makefile')
-rw-r--r--security/clamcour/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/clamcour/Makefile b/security/clamcour/Makefile
index 6b0ef35743f8..352626875aa0 100644
--- a/security/clamcour/Makefile
+++ b/security/clamcour/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamcour
PORTVERSION= 0.3.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security mail
MASTER_SITES= http://www.becrux.com/pages/projects/clamcour/
@@ -15,7 +15,7 @@ MAINTAINER= bsd@dino.sk
COMMENT= ClamAV courier filter
BUILD_DEPENDS= courier-config:${PORTSDIR}/mail/courier
-LIB_DEPENDS= clamav.5:${PORTSDIR}/security/clamav
+LIB_DEPENDS= clamav.6:${PORTSDIR}/security/clamav
GNU_CONFIGURE= yes
@@ -24,10 +24,15 @@ CONFIGURE_ARGS= --with-clamav-config=${LOCALBASE}/bin \
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
MAN1= clamcour.1
PLIST_DIRS= etc/courier/clamcour
PLIST_FILES= libexec/filters/clamcour
+post-patch:
+ @${REINPLACE_CMD} -e 's/^CXXFLAGS *=/CXXFLAGS?=/g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/cl_limits/d; s/cl_node/cl_engine/' \
+ ${WRKSRC}/src/clam.h
+
.include <bsd.port.mk>