aboutsummaryrefslogtreecommitdiffstats
path: root/security/cp2fwb/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-18 20:04:26 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-18 20:04:26 +0800
commit13657ccdcb3a9c7c4fce88aba1ab37e9167e50d2 (patch)
tree0a767bd566f573b4ff7f72c79ceb23905c03c81d /security/cp2fwb/Makefile
parent4a0c6dcb52c881bd80b78545789f58de00099fca (diff)
downloadfreebsd-ports-gnome-13657ccdcb3a9c7c4fce88aba1ab37e9167e50d2.tar.gz
freebsd-ports-gnome-13657ccdcb3a9c7c4fce88aba1ab37e9167e50d2.tar.zst
freebsd-ports-gnome-13657ccdcb3a9c7c4fce88aba1ab37e9167e50d2.zip
add cp2fwb 0.6
Checkpoint FW1 to Firewall Builder ruleset converter PR: 37298 Submitted by: Christian Brueffer <chris@unixpages.org>
Diffstat (limited to 'security/cp2fwb/Makefile')
-rw-r--r--security/cp2fwb/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/cp2fwb/Makefile b/security/cp2fwb/Makefile
new file mode 100644
index 000000000000..0565f0ef009b
--- /dev/null
+++ b/security/cp2fwb/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cp2fwb
+# Date created: 20 April 2002
+# Whom: Christian Brueffer <chris@unixpages.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cp2fwb
+PORTVERSION= 0.6
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cp2fwbuilder
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= chris@unixpages.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cp2fwbuilder ${PREFIX}/bin
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>