aboutsummaryrefslogtreecommitdiffstats
path: root/security/crank/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-04-19 03:43:17 +0800
committerijliao <ijliao@FreeBSD.org>2001-04-19 03:43:17 +0800
commit1e27029f11597b61787a0883b43558d456466e20 (patch)
treefe735a287bb294b0f2da9b8e148c755892e38ad4 /security/crank/Makefile
parent11b07f069fa63a146ac98cdde459738b239e1cb3 (diff)
downloadfreebsd-ports-gnome-1e27029f11597b61787a0883b43558d456466e20.tar.gz
freebsd-ports-gnome-1e27029f11597b61787a0883b43558d456466e20.tar.zst
freebsd-ports-gnome-1e27029f11597b61787a0883b43558d456466e20.zip
add crank
CRyptANalysis toolKit
Diffstat (limited to 'security/crank/Makefile')
-rw-r--r--security/crank/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/crank/Makefile b/security/crank/Makefile
new file mode 100644
index 000000000000..8d34a529e7ef
--- /dev/null
+++ b/security/crank/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: Crank
+# Date created: Apr 18, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crank
+PORTVERSION= 0.1.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_GTK= yes
+USE_GMAKE= yes
+
+post-patch:
+.for file in Makefile plugin-src/Makefile
+ @${PERL} -pi -e "s,gtk-config,${GTK_CONFIG},g" ${WRKSRC}/${file}
+.endfor
+ @${PERL} -pi -e "s,plugins,${PREFIX}/lib/crank,g" ${WRKSRC}/crank.h
+ @${PERL} -pi -e "s, -g , ,g" ${WRKSRC}/plugin-src/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/crank ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/crank
+ @${CP} ${WRKSRC}/plugin-src/*.so ${PREFIX}/lib/crank
+
+.include <bsd.port.mk>