aboutsummaryrefslogtreecommitdiffstats
path: root/security/cryptlib
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-09-15 02:36:52 +0800
committerale <ale@FreeBSD.org>2006-09-15 02:36:52 +0800
commit3168fcc5dd7b38b6ea4ecf62d42d9d10cfcb59b9 (patch)
tree3eb86516c140a4031e40d6ff2174c4aa5fa4cbb2 /security/cryptlib
parent5516468b3641f1592e0563d76f336868d310c106 (diff)
downloadfreebsd-ports-gnome-3168fcc5dd7b38b6ea4ecf62d42d9d10cfcb59b9.tar.gz
freebsd-ports-gnome-3168fcc5dd7b38b6ea4ecf62d42d9d10cfcb59b9.tar.zst
freebsd-ports-gnome-3168fcc5dd7b38b6ea4ecf62d42d9d10cfcb59b9.zip
Update to 3.3 release.
Diffstat (limited to 'security/cryptlib')
-rw-r--r--security/cryptlib/Makefile12
-rw-r--r--security/cryptlib/distinfo6
-rw-r--r--security/cryptlib/files/patch-context_ctx_aes.c14
-rw-r--r--security/cryptlib/files/patch-misc_os_spec.c11
-rw-r--r--security/cryptlib/pkg-plist2
5 files changed, 24 insertions, 21 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 51170882eccf..7546bef958be 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cryptlib
-PORTVERSION= 3.2.3
+PORTVERSION= 3.3
CATEGORIES= security
MASTER_SITES= ftp://ftp.franken.de/pub/crypt/cryptlib/
DISTNAME= cl${PORTVERSION:S/.//g}
@@ -33,17 +33,17 @@ PORTDOCS= README
post-patch:
.if defined(WITH_OPTIMIZED_CFLAGS)
- ${REINPLACE_CMD} -e 's/%%CFLAGS%%/${CFLAGS:N-O*:N-f*} -fomit-frame-pointer -O3/' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's/%%CFLAGS%%/${CFLAGS:N-O*:N-f*} -fomit-frame-pointer -O3/' ${WRKSRC}/makefile
.else
- ${REINPLACE_CMD} -e 's/%%CFLAGS%%/${CFLAGS}/' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's/%%CFLAGS%%/${CFLAGS}/' ${WRKSRC}/makefile
.endif
- ${REINPLACE_CMD} -e 's/%%PTHREAD_CFLAGS%%/${PTHREAD_CFLAGS}/;s/%%PTHREAD_LIBS%%/${PTHREAD_LIBS}/' \
+ @${REINPLACE_CMD} -e 's/%%PTHREAD_CFLAGS%%/${PTHREAD_CFLAGS}/;s/%%PTHREAD_LIBS%%/${PTHREAD_LIBS}/' \
${WRKSRC}/makefile
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libcl.a ${WRKSRC}/libcl.so.${PORTVERSION} \
+ ${INSTALL_DATA} ${WRKSRC}/libcl.a ${WRKSRC}/libcl.so.${PORTVERSION}.0 \
${PREFIX}/lib
- ${LN} -sf ${PREFIX}/lib/libcl.so.${PORTVERSION} ${PREFIX}/lib/libcl.so.3
+ ${LN} -sf ${PREFIX}/lib/libcl.so.${PORTVERSION}.0 ${PREFIX}/lib/libcl.so.3
${LN} -sf ${PREFIX}/lib/libcl.so.3 ${PREFIX}/lib/libcl.so
${INSTALL_DATA} ${WRKSRC}/cryptlib.h ${PREFIX}/include
diff --git a/security/cryptlib/distinfo b/security/cryptlib/distinfo
index 4450f70030fd..102ce4c1825c 100644
--- a/security/cryptlib/distinfo
+++ b/security/cryptlib/distinfo
@@ -1,3 +1,3 @@
-MD5 (cl323.zip) = db26fcb1060afe2840fef9cb4bae7b1e
-SHA256 (cl323.zip) = 208acb1351c6a1f93a5f07ba9a5ffcffc4eec3dceba9b823a1b0018a2a58c7fd
-SIZE (cl323.zip) = 3730765
+MD5 (cl33.zip) = 50383f20dfe79c401540d083c7d52084
+SHA256 (cl33.zip) = 73d72b005aeb75da7d385e762f4e8cdcff9ac75d17152c980545a654c7d9c2f5
+SIZE (cl33.zip) = 3777255
diff --git a/security/cryptlib/files/patch-context_ctx_aes.c b/security/cryptlib/files/patch-context_ctx_aes.c
new file mode 100644
index 000000000000..eeb5479c06ce
--- /dev/null
+++ b/security/cryptlib/files/patch-context_ctx_aes.c
@@ -0,0 +1,14 @@
+--- context/ctx_aes.c.orig Thu Sep 14 20:29:24 2006
++++ context/ctx_aes.c Thu Sep 14 20:30:14 2006
+@@ -67,10 +67,10 @@
+ is a relatively minor overhead compared to en/decryption, so it's not a
+ big problem) */
+
++#define L_SIZE( x ) ( sizeof( x ) / sizeof( unsigned long ) )
+ #if defined( USE_VIA_ACE_IF_PRESENT )
+ /* Data is DWORD-aligned anyway but we need to have 16-byte alignment for
+ key data in case we're using the VIA ACE */
+- #define L_SIZE( x ) ( sizeof( x ) / sizeof( unsigned long ) )
+ #define KS_SIZE ( sizeof( AES_EKEY ) + sizeof( AES_DKEY ) + 24 )
+ #define ALGN( x ) ( ( unsigned long )( x ) & 0xFFFFFFF0 )
+ #define EKEY( x ) ( ( AES_EKEY * ) ALGN( ( ( AES_CTX * ) x )->ksch + 3 ) )
diff --git a/security/cryptlib/files/patch-misc_os_spec.c b/security/cryptlib/files/patch-misc_os_spec.c
deleted file mode 100644
index f8554713156c..000000000000
--- a/security/cryptlib/files/patch-misc_os_spec.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- misc/os_spec.c.orig Fri Jul 14 08:46:10 2006
-+++ misc/os_spec.c Fri Jul 14 08:46:38 2006
-@@ -1275,7 +1275,7 @@
- return( sysCaps );
- }
-
--#elif defined( __GNUC__ ) && defined( __i386__ )
-+#elif defined( __GNUC__ ) && defined( __i386__ ) && !defined(__FreeBSD__)
-
- #if SYSCAP_FLAG_RDTSC != 0x01
- #error Need to sync SYSCAP_FLAG_RDTSC with equivalent asm definition
diff --git a/security/cryptlib/pkg-plist b/security/cryptlib/pkg-plist
index c1e823732b55..7e7fc39ff0a5 100644
--- a/security/cryptlib/pkg-plist
+++ b/security/cryptlib/pkg-plist
@@ -2,4 +2,4 @@ include/cryptlib.h
lib/libcl.a
lib/libcl.so
lib/libcl.so.3
-lib/libcl.so.3.2.3
+lib/libcl.so.3.3.0