aboutsummaryrefslogtreecommitdiffstats
path: root/security/cryptopp
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-30 15:07:16 +0800
committermarino <marino@FreeBSD.org>2014-07-30 15:07:16 +0800
commit60f0d29ca95721c3e5088a09ba54ff253af729e0 (patch)
treebae3d8b5919b6b8c0da65e411ed9e601c5ca0b78 /security/cryptopp
parentfd0e7d3cd0bcfd58f8fc43727bad1cd5d3e3d259 (diff)
downloadfreebsd-ports-gnome-60f0d29ca95721c3e5088a09ba54ff253af729e0.tar.gz
freebsd-ports-gnome-60f0d29ca95721c3e5088a09ba54ff253af729e0.tar.zst
freebsd-ports-gnome-60f0d29ca95721c3e5088a09ba54ff253af729e0.zip
security/cryptopp: Add patch from pkgsrc
The definition of CRYPTOPP_BOOL_ALIGN16_ENABLED was incorrect for i386. For NetBSD, this resulted in the inability to build cryptopp on i386. On FreeBSD, it built, but deskutils/cdcat choked on it while building on FreeBSD 10/i386 and FreeBSD 11/i386. PR: 192199 Fix from: pkgsrc security/crypto++ Discussed: NetBSD GNATS 48134 Approved by: delphi@
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile2
-rw-r--r--security/cryptopp/files/patch-config.h29
2 files changed, 30 insertions, 1 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 4b0fca2bbbfa..e526737669d7 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cryptopp
PORTVERSION= 5.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF \
http://www.cryptopp.com/
diff --git a/security/cryptopp/files/patch-config.h b/security/cryptopp/files/patch-config.h
new file mode 100644
index 000000000000..a8f312da25be
--- /dev/null
+++ b/security/cryptopp/files/patch-config.h
@@ -0,0 +1,29 @@
+--- config.h.orig 2013-02-20 14:30:54.000000000 +0000
++++ config.h
+@@ -290,12 +290,6 @@ NAMESPACE_END
+ #define CRYPTOPP_BOOL_AESNI_INTRINSICS_AVAILABLE 0
+ #endif
+
+-#if CRYPTOPP_BOOL_SSE2_INTRINSICS_AVAILABLE || CRYPTOPP_BOOL_SSE2_ASM_AVAILABLE || defined(CRYPTOPP_X64_MASM_AVAILABLE)
+- #define CRYPTOPP_BOOL_ALIGN16_ENABLED 1
+-#else
+- #define CRYPTOPP_BOOL_ALIGN16_ENABLED 0
+-#endif
+-
+ // how to allocate 16-byte aligned memory (for SSE2)
+ #if defined(CRYPTOPP_MSVC6PP_OR_LATER)
+ #define CRYPTOPP_MM_MALLOC_AVAILABLE
+@@ -307,6 +301,13 @@ NAMESPACE_END
+ #define CRYPTOPP_NO_ALIGNED_ALLOC
+ #endif
+
++#if CRYPTOPP_BOOL_SSE2_INTRINSICS_AVAILABLE || CRYPTOPP_BOOL_SSE2_ASM_AVAILABLE || defined(CRYPTOPP_X64_MASM_AVAILABLE) || !defined(CPRYPTO_NO_ALIGNED_ALLOC)
++ #define CRYPTOPP_BOOL_ALIGN16_ENABLED 1
++#else
++ #define CRYPTOPP_BOOL_ALIGN16_ENABLED 0
++#endif
++
++
+ // how to disable inlining
+ #if defined(_MSC_VER) && _MSC_VER >= 1300
+ # define CRYPTOPP_NOINLINE_DOTDOTDOT